summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-25 18:13:57 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-25 18:13:57 +0000
commite1c4a0e78154dc37e07692717fe191e44cd3d29b (patch)
tree927b27d79cf470a5da866c36a0e8e0020e715dd1 /dev-lang/python/python-2.3.3.ebuild
parentglibc ----------------------------> libc ! (diff)
downloadhistorical-e1c4a0e78154dc37e07692717fe191e44cd3d29b.tar.gz
historical-e1c4a0e78154dc37e07692717fe191e44cd3d29b.tar.bz2
historical-e1c4a0e78154dc37e07692717fe191e44cd3d29b.zip
QA - fix use invocation and a bug in the 2.3.4 ebuilds: [ -z "use X" -o -z "use tcltk" ] doesn't do what you meant it to do
Diffstat (limited to 'dev-lang/python/python-2.3.3.ebuild')
-rw-r--r--dev-lang/python/python-2.3.3.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index b9195edae985..7423206eb082 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.26 2004/06/24 22:54:46 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.27 2004/06/25 18:13:57 agriffis Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -70,7 +70,7 @@ src_configure() {
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} dbm bsddb"
use readline \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} readline"
- [ -z "`use X`" -o -z "`use tcltk`" ] \
+ ( use !X || use !tcltk ) \
&& PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _tkinter"
use ncurses \
|| PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
@@ -92,7 +92,7 @@ src_compile() {
local myconf
#if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]; then
+ if use build && ! use bootstrap; then
myconf="--with-cxx=no"
fi