summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-11-27 12:50:14 +0000
committerSebastian Pipping <sping@gentoo.org>2010-11-27 12:50:14 +0000
commitfc14a6dfc961d2f8c9c30d82a4a367347b70a05c (patch)
treedc21e89ddfc9c151d9fdbe165f0053460d0f721a /dev-lang/python/python-2.5.4-r4.ebuild
parentRemove masking of ghc-6.12.1 and ghc-6.12.2. (diff)
downloadhistorical-fc14a6dfc961d2f8c9c30d82a4a367347b70a05c.tar.gz
historical-fc14a6dfc961d2f8c9c30d82a4a367347b70a05c.tar.bz2
historical-fc14a6dfc961d2f8c9c30d82a4a367347b70a05c.zip
dev-lang/python: Disable auto-bumping of active Python version by removing eselect_python_update() and its invocation as explained and announced on gentoo-dev
Package-Manager: portage-2.1.9.24/cvs/Linux x86_64
Diffstat (limited to 'dev-lang/python/python-2.5.4-r4.ebuild')
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild16
1 files changed, 1 insertions, 15 deletions
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index adef9a92d6a1..059dac626975 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.23 2010/07/10 13:06:28 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.24 2010/11/27 12:50:14 sping Exp $
EAPI="1"
@@ -284,19 +284,7 @@ pkg_preinst() {
fi
}
-eselect_python_update() {
- local eselect_python_options
- [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
-
- # Create python2 symlink.
- eselect python update --python2 > /dev/null
-
- eselect python update ${eselect_python_options}
-}
-
pkg_postinst() {
- eselect_python_update
-
python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
@@ -313,7 +301,5 @@ pkg_postinst() {
}
pkg_postrm() {
- eselect_python_update
-
python_mod_cleanup $(python_get_libdir)
}