summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Gabert <pappy@gentoo.org>2003-10-03 15:51:39 +0000
committerAlexander Gabert <pappy@gentoo.org>2003-10-03 15:51:39 +0000
commit30b9b50c1ee8391187cf7316bf45217f722589eb (patch)
treeebf046c11dc600f783ec4fdbdcc89087caa0db85 /dev-lang/python
parentfilter-flags because of segfaulting with fstackprotector in CFLAGS (diff)
downloadhistorical-30b9b50c1ee8391187cf7316bf45217f722589eb.tar.gz
historical-30b9b50c1ee8391187cf7316bf45217f722589eb.tar.bz2
historical-30b9b50c1ee8391187cf7316bf45217f722589eb.zip
filter-flags because of segfaulting with fstackprotector in CFLAGS
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/Manifest4
-rw-r--r--dev-lang/python/python-2.2.3-r1.ebuild5
2 files changed, 6 insertions, 3 deletions
diff --git a/dev-lang/python/Manifest b/dev-lang/python/Manifest
index b1ffccbcc935..2684f21e22e4 100644
--- a/dev-lang/python/Manifest
+++ b/dev-lang/python/Manifest
@@ -3,8 +3,8 @@ MD5 789d8555967a31cc0de2126fa6468fc2 python-2.2.3.ebuild 2999
MD5 c70d578ef0b3e6358108691e8b88d458 python-2.2.2.ebuild 3027
MD5 58b06d58bccd371fcbf1b781164c75a9 python-2.1.3-r1.ebuild 2345
MD5 f7959cf61958991a7e25f83a4e8b2ff8 python-2.2.1-r5.ebuild 2912
-MD5 2691e0a249b1b6ed3f6101a41d028fef python-2.2.3-r1.ebuild 3300
-MD5 565a4e4ef3242523268eb155ef88a97b ChangeLog 6144
+MD5 a6d5e6ba5a71df331fc7aed402038ed6 python-2.2.3-r1.ebuild 3294
+MD5 289cc80711b3a11ceb82824733ab7f31 ChangeLog 6138
MD5 8145ce0144332d6caca98fa5fb648741 metadata.xml 221
MD5 5f2361b3e770981b737a9ad3d2863931 files/python-2.2.1-r5-gentoo.diff 4152
MD5 b7a6b00d8dede1534e7a5180a14542b1 files/digest-python-2.2.2 62
diff --git a/dev-lang/python/python-2.2.3-r1.ebuild b/dev-lang/python/python-2.2.3-r1.ebuild
index 0abe794f860f..d1257ee3426e 100644
--- a/dev-lang/python/python-2.2.3-r1.ebuild
+++ b/dev-lang/python/python-2.2.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r1.ebuild,v 1.8 2003/09/23 15:47:26 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.3-r1.ebuild,v 1.9 2003/10/03 15:51:33 pappy Exp $
IUSE="readline tcltk berkdb bootstrap build doc"
@@ -46,6 +46,9 @@ src_unpack() {
src_compile() {
filter-flags -malign-double
+
+ # during building, ./python -E segfaults with propolice
+ filter-flags -fstack-protector
[ "${ARCH}" = "hppa" ] && append-flags -fPIC
[ "${ARCH}" = "alpha" ] && append-flags -fPIC