summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-18 21:01:05 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-02-18 21:01:05 +0000
commit6a8c85eb83d6a84302e13f6f8aebbc9cbdc54ba8 (patch)
treec6f5e200c945771e185654dfabd5193119406042 /dev-lang
parentlcrzo 4.04 (diff)
downloadhistorical-6a8c85eb83d6a84302e13f6f8aebbc9cbdc54ba8.tar.gz
historical-6a8c85eb83d6a84302e13f6f8aebbc9cbdc54ba8.tar.bz2
historical-6a8c85eb83d6a84302e13f6f8aebbc9cbdc54ba8.zip
Updated Java support
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog21
-rw-r--r--dev-lang/php/files/digest-php-4.0.6-r51
-rw-r--r--dev-lang/php/files/digest-php-4.1.1-r31
-rw-r--r--dev-lang/php/php-4.0.6-r5.ebuild160
-rw-r--r--dev-lang/php/php-4.1.1-r3.ebuild (renamed from dev-lang/php/php-4.1.1-r2.ebuild)19
5 files changed, 199 insertions, 3 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 85faac5bcc41..afb3beb26b18 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.3 2002/02/12 17:44:44 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.4 2002/02/18 21:01:05 karltk Exp $
+
+*php-4.0.6-r5 ( 18 Feb 2002 )
+
+ 18 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> php-4.0.6-r4.ebuild
+
+ As Java support fails to work with Blackdown, and the fix seems non-trivial,
+ Java support is removed from PHP 4.0.6 altogether.
+
+ Old revisions have been removed.
*php-4.0.6-r4 ( 12 Feb 2002 )
@@ -11,9 +20,17 @@
Old revisions have been removed.
+*php-4.1.1-r3 ( 18 Feb 2002 )
+
+ 18 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> php-4.1.1-r3.ebuild
+
+ Java is still here, but now it actually works with Blackdown as well.
+
+ Old revisions have been removed.
+
*php-4.1.1-r2 ( 12 Feb 2002 )
- 12 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> php-4.1.1-r4.ebuild
+ 12 Feb 2002; Karl Trygve Kalleberg <karltk@gentoo.org> php-4.1.1-r2.ebuild
Java support is back. The ebuild also tries harder to follow the style
guide.
diff --git a/dev-lang/php/files/digest-php-4.0.6-r5 b/dev-lang/php/files/digest-php-4.0.6-r5
new file mode 100644
index 000000000000..82f9b239e415
--- /dev/null
+++ b/dev-lang/php/files/digest-php-4.0.6-r5
@@ -0,0 +1 @@
+MD5 5f698521cf2b392cf9bfa87fc1a0fe90 php-4.0.6.tar.gz 3157346
diff --git a/dev-lang/php/files/digest-php-4.1.1-r3 b/dev-lang/php/files/digest-php-4.1.1-r3
new file mode 100644
index 000000000000..d7e8f2b826d9
--- /dev/null
+++ b/dev-lang/php/files/digest-php-4.1.1-r3
@@ -0,0 +1 @@
+MD5 776362ff53bf6ea77b60496f6632b6b6 php-4.1.1.tar.gz 3356062
diff --git a/dev-lang/php/php-4.0.6-r5.ebuild b/dev-lang/php/php-4.0.6-r5.ebuild
new file mode 100644
index 000000000000..0060675e2e3e
--- /dev/null
+++ b/dev-lang/php/php-4.0.6-r5.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.0.6-r5.ebuild,v 1.1 2002/02/18 21:01:05 karltk Exp $
+
+A=${PN}-4.0.6.tar.gz
+S=${WORKDIR}/${PN}-4.0.6
+DESCRIPTION="HTML embedded scripting language"
+SRC_URI="http://www.php.net/distributions/${A}"
+HOMEPAGE="http://www.php.net/"
+
+DEPEND="virtual/glibc
+ >=dev-libs/gmp-3.1.1
+ ~media-libs/freetype-1.3.1
+ >=media-libs/jpeg-6b
+ >=media-libs/tiff-3.5.5
+ >=media-libs/libpng-1.0.7
+ >=media-libs/libgd-1.8.3
+ >=media-libs/t1lib-1.0.1
+ >=net-www/apache-1.3
+ pam? ( >=sys-libs/pam-0.75 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ gettext? ( sys-devel/gettext )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ berkdb? ( >=sys-libs/db-3 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ X? ( virtual/x11 )
+ qt? ( =x11-libs/qt-2.3* )
+ xml? ( >=app-text/sablotron-0.44 )
+ libwww? ( >=net-libs/libwww-5.3.2 )
+ imap? ( virtual/imap )
+ flash? ( media-libs/libswf media-libs/ming )
+ xml2? ( dev-libs/libxml2 )
+ java? ( virtual/jdk )
+ "
+
+RDEPEND="virtual/glibc
+ >=dev-libs/gmp-3.1.1
+ ~media-libs/freetype-1.3.1
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.0.7
+ >=media-libs/t1lib-1.0.1
+ >=net-www/apache-1.3
+ pam? ( >=sys-libs/pam-0.75 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ berkdb? ( >=sys-libs/db-3 )
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ X? ( virtual/x11 )
+ qt? ( >=x11-libs/qt-2.3.0 )
+ xml? ( >=app-text/sablotron-0.44 )
+ libwww? ( >=net-libs/libwww-5.3.2 )
+ xml2? ( dev-libs/libxml2 )
+ imap? ( virtual/imap )
+ "
+src_compile() {
+
+ local myconf
+
+ use readline && myconf="${myconf} --with-readline"
+ use pam && myconf="${myconf} --with-pam"
+ use gettext && myconf="${myconf} --with-gettext"
+ use gdbm && myconf="${myconf} --with-gdbm=/usr"
+ use berkdb && myconf="${myconf} --with-db3=/usr"
+ use mysql && myconf="${myconf} --with-mysql=/usr"
+ use postgres && myconf="${myconf} --with-pgsql=/usr"
+ use odbc && myconf="${myconf} --with-unixODBC=/usr"
+ use ldap && myconf="${myconf} --with-ldap"
+ use imap && myconf="${myconf} --with-imap"
+
+ if [ "`use qt`" ] ; then
+ EXPORT QTDIR=/usr/qt/2 #hope this helps - danarmak
+ myconf="$myconf --with-qtdom"
+ fi
+
+ use libwww && myconf="${myconf} --with-xml" || myconf="${myconf} --disable-xml"
+ use flash && myconf="${myconf} --with-swf=/usr --with-ming=/usr"
+
+ if [ "`use xml`" ] ; then
+ export LIBS="-lxmlparse -lxmltok"
+ myconf="$myconf --with-sablot=/usr"
+ fi
+
+ use xml2 && myconf="${myconf} --with-dom"
+
+ LDFLAGS="$LDFLAGS -ltiff -ljpeg"
+
+ if [ "`use X`" ] ; then
+ myconf="$myconf --with-xpm-dir=/usr/X11R6"
+ LDFLAGS="$LDFLAGS -L/usr/X11R6/lib"
+ fi
+
+
+
+ ./configure --enable-safe-mode \
+ --enable-ftp \
+ --enable-track-vars \
+ --with-gmp \
+ --enable-dbase \
+ --enable-sysvsem \
+ --enable-sysvshm \
+ --with-zlib=yes \
+ --enable-bcmath \
+ --enable-calendar \
+ --enable-versioning \
+ --enable-inline-optimization \
+ --enable-trans-sid \
+ --with-gd \
+ --with-ttf \
+ --with-t1lib \
+ --with-jpeg-dir=/usr/lib \
+ --prefix=/usr \
+ --with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
+ --host=${CHOST} \
+ --with-apxs="/usr/sbin/apxs -ltiff" \
+ --with-exec-dir="/usr/lib/apache/bin" \
+ $myconf || die "./configure failed"
+
+ make || die
+}
+
+
+src_install() {
+
+ make INSTALL_ROOT=${D} install-pear || die
+ dodir /usr/lib/apache
+ cp .libs/libphp4.so ${D}/usr/lib/apache
+
+ dodir /etc/httpd
+ cp php.ini-dist ${D}/etc/httpd/php.ini
+ dodoc CODING_STANDARDS LICENSE EXTENSIONS
+ dodoc RELEASE_PROCESS README.* TODO NEWS
+ dodoc ChangeLog* *.txt
+}
+
+pkg_config() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ if [ -f "${ROOT}/etc/httpd/httpd.conf" ] ; then
+
+ # Activate PHP-Extension in httpd.conf
+ einfo "Activate PHP in httpd.conf..."
+ cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
+ sed -e "s/^#LoadModule php4_module/LoadModule php4_module/" \
+ -e "s/^#AddModule mod_php4.c/AddModule mod_php4.c/" \
+ -e "s/#AddType application\/x-httpd-php /AddType application\/x-httpd-php /" \
+ -e "s/#AddType application\/x-httpd-php-/AddType application\/x-httpd-php-/" \
+ ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
+ fi
+}
+
+
+
diff --git a/dev-lang/php/php-4.1.1-r2.ebuild b/dev-lang/php/php-4.1.1-r3.ebuild
index 16d60c3f5c1c..0204800fd202 100644
--- a/dev-lang/php/php-4.1.1-r2.ebuild
+++ b/dev-lang/php/php-4.1.1-r3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Tools Team <tools@gentoo.org>
# Author: Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.1.1-r2.ebuild,v 1.1 2002/02/12 17:44:44 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-4.1.1-r3.ebuild,v 1.1 2002/02/18 21:01:05 karltk Exp $
S=${WORKDIR}/${P}
DESCRIPTION="HTML embedded scripting language"
@@ -62,6 +62,23 @@ RDEPEND="virtual/glibc
java? ( virtual/jdk )
"
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ if [ "`use java`" ] ; then
+
+ cp configure configure.orig
+ cat configure.orig | \
+ sed -e 's/LIBS="-lttf $LIBS"/LIBS="-lttf -lhpi $LIBS"/' \
+ > configure
+
+ cp ext/gd/gd.c ext/gd/gd.c.orig
+ cat ext/gd/gd.c.orig | \
+ sed -e "s/typedef FILE gdIOCtx;//" \
+ > ext/gd/gd.c
+ fi
+}
+
src_compile() {
local myconf