summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-02-23 01:05:12 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-02-23 01:05:12 +0000
commit8cc8fe997649a86758915eaf0062d55b7d6eafd2 (patch)
tree03b471c0a500a4e63d5ed9398086aceff18f53d4 /dev-lang
parentAdded ~hppa to keywords. (diff)
downloadhistorical-8cc8fe997649a86758915eaf0062d55b7d6eafd2.tar.gz
historical-8cc8fe997649a86758915eaf0062d55b7d6eafd2.tar.bz2
historical-8cc8fe997649a86758915eaf0062d55b7d6eafd2.zip
Added -fPIC to CFLAGS on hppa. It's needed by apps linking to some python libs.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog5
-rw-r--r--dev-lang/python/python-2.2.2.ebuild4
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index bf81454acf7c..ea83119a6eb5 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.24 2003/02/22 07:44:57 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.25 2003/02/23 01:05:12 gmsoft Exp $
+
+ 23 Feb 2003; Guy Martin <gmsoft@gentoo.org> python-2.2.2.ebuild :
+ Added -fPIC to CFLAGS on hppa. It's needed by apps linking to some python libs.
21 Feb 2003; Zach Welch <zwelch@gentoo.org> python-2.2.2.ebuild :
Added arm to keywords.
diff --git a/dev-lang/python/python-2.2.2.ebuild b/dev-lang/python/python-2.2.2.ebuild
index 3fc1d926e046..441a98dcbaa1 100644
--- a/dev-lang/python/python-2.2.2.ebuild
+++ b/dev-lang/python/python-2.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.2.ebuild,v 1.8 2003/02/22 07:44:57 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.2.2.ebuild,v 1.9 2003/02/23 01:05:12 gmsoft Exp $
IUSE="readline tcltk berkdb bootstrap"
@@ -40,6 +40,8 @@ inherit flag-o-matic
src_compile() {
filter-flags -malign-double
+ [ "${ARCH}" = "hppa" ] && append-flags -fPIC
+
if [ "${ARCH}" = "alpha" ]; then
CFLAGS="${CFLAGS} -fPIC"
CXXFLAGS="${CXXFLAGS} -fPIC"