summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-06 06:00:16 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-06 06:00:16 +0000
commitd9eb80c101a6e65d838374a4810dc18dd730c0d6 (patch)
tree94df331cfc9eabb78d6b029ec541e7db2fbb55c0 /dev-lang
parentNew revision see ChangeLog, package.mask and bug #3431 (diff)
downloadhistorical-d9eb80c101a6e65d838374a4810dc18dd730c0d6.tar.gz
historical-d9eb80c101a6e65d838374a4810dc18dd730c0d6.tar.bz2
historical-d9eb80c101a6e65d838374a4810dc18dd730c0d6.zip
Added Firebird support. Fixes #3304
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog6
-rw-r--r--dev-lang/php/php-4.2.1-r1.ebuild3
2 files changed, 7 insertions, 2 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index ceb6fe0e599d..58e14e4c65e3 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for dev-lang/php
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.27 2002/05/21 15:45:15 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.28 2002/06/06 06:00:16 rphillips Exp $
27 Apr 2002; Ryan Phillips <rphillips@gentoo.org> :
@@ -21,6 +21,10 @@
*php-4.2.1-r1 (21 May 2002)
+ 5 June 2002; Ryan Phillips <rphillips@gentoo.org> php-4.2.1-r1.ebuild :
+
+ Added support for firebird
+
21 May 2002; Roman Weber <gentoo@gonzo.ch> php-4.2.1-r1.ebuild :
Added XSLT sablotron to XML USE variable. Bug #2863
diff --git a/dev-lang/php/php-4.2.1-r1.ebuild b/dev-lang/php/php-4.2.1-r1.ebuild
index b2ca5eaa1869..59b8b9406a09 100644
--- a/dev-lang/php/php-4.2.1-r1.ebuild
+++ b/dev-lang/php/php-4.2.1-r1.ebuild
@@ -38,6 +38,7 @@ DEPEND=">=dev-libs/gmp-3.1.1
flash? ( media-libs/libswf >=media-libs/ming-0.2a )
berkdb? ( >=sys-libs/db-3 )
libwww? ( >=net-libs/libwww-5.3.2 )
+ firebird? ( >=dev-db/firebird-1.0 )
pdflib? ( >=media-libs/pdflib-4.0.1-r2 )
postgres? ( >=dev-db/postgresql-7.1 )"
# java? ( virtual/jdk )
@@ -97,7 +98,7 @@ src_compile() {
use odbc && myconf="${myconf} --with-unixODBC=/usr"
use ldap && myconf="${myconf} --with-ldap"
use pdflib && myconf="${myconf} --with-pdflib=/usr"
-
+ use firebird && myconf="${myconf} --with-interbase=/opt/interbase"
use qt && ( \
export QTDIR=/usr/qt/2 #hope this helps - danarmak