summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-06-11 19:14:22 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-06-11 19:14:22 +0000
commit488e9b5f9b6dd20f62536954706a656f866cb6f5 (patch)
tree193270e5cc51239755528cbd3b7185776d61bfae /dev-libs/apr-util
parentfix #220353 (diff)
downloadhistorical-488e9b5f9b6dd20f62536954706a656f866cb6f5.tar.gz
historical-488e9b5f9b6dd20f62536954706a656f866cb6f5.tar.bz2
historical-488e9b5f9b6dd20f62536954706a656f866cb6f5.zip
version bump wrt #225783
Package-Manager: portage-2.1.5.4
Diffstat (limited to 'dev-libs/apr-util')
-rw-r--r--dev-libs/apr-util/ChangeLog7
-rw-r--r--dev-libs/apr-util/apr-util-1.3.0.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/dev-libs/apr-util/ChangeLog b/dev-libs/apr-util/ChangeLog
index 2a5d704cab2f..17bd8682ad72 100644
--- a/dev-libs/apr-util/ChangeLog
+++ b/dev-libs/apr-util/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/apr-util
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.107 2008/06/01 11:42:35 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/ChangeLog,v 1.108 2008/06/11 19:14:22 hollow Exp $
+
+*apr-util-1.3.0 (11 Jun 2008)
+
+ 11 Jun 2008; Benedikt Böhm <hollow@gentoo.org> +apr-util-1.3.0.ebuild:
+ version bump wrt #225783
01 Jun 2008; Benedikt Böhm <hollow@gentoo.org> apr-util-1.2.10.ebuild,
apr-util-1.2.12.ebuild:
diff --git a/dev-libs/apr-util/apr-util-1.3.0.ebuild b/dev-libs/apr-util/apr-util-1.3.0.ebuild
new file mode 100644
index 000000000000..663c47cfa74f
--- /dev/null
+++ b/dev-libs/apr-util/apr-util-1.3.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/apr-util/apr-util-1.3.0.ebuild,v 1.1 2008/06/11 19:14:22 hollow Exp $
+
+inherit autotools eutils flag-o-matic libtool db-use
+
+DESCRIPTION="Apache Portable Runtime Utility Library"
+HOMEPAGE="http://apr.apache.org/"
+SRC_URI="mirror://apache/apr/${P}.tar.gz
+ mirror://apache/apr/apr-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="berkdb doc gdbm ldap mysql postgres sqlite sqlite3"
+RESTRICT="test"
+
+RDEPEND="dev-libs/expat
+ >=dev-libs/apr-${PV}
+ berkdb? ( =sys-libs/db-4* )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( =net-nds/openldap-2* )
+ mysql? ( =virtual/mysql-5* )
+ postgres? ( virtual/postgresql-base )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ ./buildconf --with-apr=../apr-${PV} || die "buildconf failed"
+ elibtoolize || die "elibtoolize failed"
+}
+
+src_compile() {
+ local myconf=""
+
+ use ldap && myconf="${myconf} --with-ldap"
+
+ if use berkdb; then
+ dbver="$(db_findver sys-libs/db)" || die "Unable to find db version"
+ dbver="$(db_ver_to_slot "$dbver")"
+ dbver="${dbver/\./}"
+ myconf="${myconf} --with-dbm=db${dbver}
+ --with-berkeley-db=$(db_includedir):/usr/$(get_libdir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ econf --datadir=/usr/share/apr-util-1 \
+ --with-apr=/usr \
+ --with-expat=/usr \
+ $(use_with gdbm) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_with sqlite sqlite2) \
+ $(use_with sqlite3) \
+ ${myconf}
+
+ emake || die "emake failed!"
+
+ if use doc; then
+ emake dox || die "emake dox failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc CHANGES NOTICE
+
+ if use doc; then
+ dohtml docs/dox/html/* || die "dohtml failed"
+ fi
+
+ # This file is only used on AIX systems, which gentoo is not,
+ # and causes collisions between the SLOTs, so kill it
+ rm "${D}"/usr/$(get_libdir)/aprutil.exp
+}