summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-03-10 04:42:33 +0000
committerDaniel Goller <morfic@gentoo.org>2005-03-10 04:42:33 +0000
commit925093e784fe6a270825f9962a716f1b6a74d3ff (patch)
tree6e406028f3261399925b76243bf9dd2e28d4eac8 /dev-libs/boost
parentScott Price: fix version options, move linux-headers into stage2, create set_... (diff)
downloadhistorical-925093e784fe6a270825f9962a716f1b6a74d3ff.tar.gz
historical-925093e784fe6a270825f9962a716f1b6a74d3ff.tar.bz2
historical-925093e784fe6a270825f9962a716f1b6a74d3ff.zip
added paths for boost to build all targets with icc
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/Manifest10
-rw-r--r--dev-libs/boost/boost-1.32.0-r1.ebuild4
3 files changed, 13 insertions, 7 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 674df983d477..322bf2013e38 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.44 2005/03/09 06:17:04 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.45 2005/03/10 04:42:33 morfic Exp $
+
+ 09 Mar 2005; Daniel Goller <morfic@gentoo.org> boost-1.32.0-r1.ebuild:
+ set paths for icc to properly build all boost targets
+ special thanks to steveb
08 Mar 2005; Daniel Goller <morfic@gentoo.org> boost-1.32.0-r1.ebuild:
adding -sINTEL_PATH="/opt/intel/compiler80/" for them icc users
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 43f52054115a..0a5acdfc81a2 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -5,9 +5,9 @@ MD5 12f996aa5f489e4e51055e537ea059a8 boost-1.31.0.ebuild 3967
MD5 8d4eca3eb59bc23e2d53b3d0cfd06c97 boost-1.32.0.ebuild 2294
MD5 d259ae434e176df207cba3deab973f61 boost-1.29.0.ebuild 1426
MD5 34d13e0eeb58e13e1992908d04d51b45 boost-1.30.0.ebuild 2973
-MD5 35748e494144a0f5dae0143a28dd07f2 ChangeLog 6649
+MD5 16c649cdb020c21f399167e397f3e333 ChangeLog 6806
MD5 ac17509c51769ef73346e3d3d7733f67 metadata.xml 347
-MD5 1824b1ef70a7d1abd7f6f24a0aadc169 boost-1.32.0-r1.ebuild 3530
+MD5 2d37194475293f6e94af0eea58480970 boost-1.32.0-r1.ebuild 3632
MD5 4759f9391ad73c487d4f6b3dbf8632a8 boost-1.30.2.ebuild 2960
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
MD5 2b36d47323b021671d391600501685cc files/digest-boost-1.30.0 66
@@ -18,7 +18,7 @@ MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r1 67
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFCLoQvUpKYMelfdYERAlnPAJ9BeJSFArqa4KZ0ROKGfm/pUJdNYwCeOPQP
-YBZ0L4dRv76paMS7p8n3gz0=
-=sFe4
+iD8DBQFCL76UUpKYMelfdYERAm4FAKCPBTNLn4GjsdAinM4XIsg2VLzNoQCaAwR4
+1HriROr++/az2lh6v7TQqKY=
+=bFvi
-----END PGP SIGNATURE-----
diff --git a/dev-libs/boost/boost-1.32.0-r1.ebuild b/dev-libs/boost/boost-1.32.0-r1.ebuild
index 0e7c4b5e173a..0901cff65fbf 100644
--- a/dev-libs/boost/boost-1.32.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.32.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.7 2005/03/09 06:17:04 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r1.ebuild,v 1.8 2005/03/10 04:42:33 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
inherit python multilib
@@ -57,6 +57,8 @@ src_install () {
cd ${S}
if use icc ; then
+ export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
+ export GXX_INCLUDE="/usr/include"
${BOOSTJAM} -sBOOST_ROOT=${S} \
-sPYTHON_ROOT=/usr \
-sPYTHON_VERSION=${PYVER} \