summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-01-29 15:50:29 +0000
committerAron Griffis <agriffis@gentoo.org>2004-01-29 15:50:29 +0000
commit936926e10480243218e386cd6229114cc996dc5e (patch)
treea244af4f2b52410a9bc8aed7c2648f5a4c7d4a80 /dev-libs/ffcall
parentInitial ebuild. (diff)
downloadhistorical-936926e10480243218e386cd6229114cc996dc5e.tar.gz
historical-936926e10480243218e386cd6229114cc996dc5e.tar.bz2
historical-936926e10480243218e386cd6229114cc996dc5e.zip
fix build on alpha to use correct CPU setting
Diffstat (limited to 'dev-libs/ffcall')
-rw-r--r--dev-libs/ffcall/Manifest2
-rw-r--r--dev-libs/ffcall/ffcall-1.8d.ebuild13
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-libs/ffcall/Manifest b/dev-libs/ffcall/Manifest
index 157c0a61eaa1..59c549c2fb84 100644
--- a/dev-libs/ffcall/Manifest
+++ b/dev-libs/ffcall/Manifest
@@ -1,4 +1,4 @@
MD5 ecd3056f801a60531f1938c87b65e989 ChangeLog 834
-MD5 983a1fad5099277a0847b9121b7d98b8 ffcall-1.8d.ebuild 1544
+MD5 3f88895c7b8636057b23f2f6dcca8fa1 ffcall-1.8d.ebuild 1788
MD5 cd13882be2b4029127ad48a9037c98bc files/digest-ffcall-1.8d 63
MD5 551cda681686392a1416ec70fecc2b94 files/ffcall_hppa_1.8-4.2.diff.gz 2416
diff --git a/dev-libs/ffcall/ffcall-1.8d.ebuild b/dev-libs/ffcall/ffcall-1.8d.ebuild
index 09d6d5a4898b..9b1d5017935a 100644
--- a/dev-libs/ffcall/ffcall-1.8d.ebuild
+++ b/dev-libs/ffcall/ffcall-1.8d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.10 2004/01/29 15:13:40 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ffcall/ffcall-1.8d.ebuild,v 1.11 2004/01/29 15:50:29 agriffis Exp $
DESCRIPTION="foreign function call libraries"
SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/libs/${P}.tar.gz"
@@ -16,8 +16,7 @@ KEYWORDS="x86 sparc ~hppa ~alpha"
DEPEND="virtual/glibc"
-src_unpack()
-{
+src_unpack() {
unpack ${A}
#Fix hppa asm
use hppa && (cd ${S}; epatch ${FILESDIR}/ffcall_hppa_1.8-4.2.diff.gz)
@@ -25,8 +24,14 @@ src_unpack()
}
src_compile() {
+ # Because CHOST is set to (for example)
+ # alphaev67-unknown-linux-gnu, CPU gets set to alphaev67 which
+ # doesn't work in the Makefile (29 Jan 2004 agriffis)
+ local cpu_setting
+ [[ $ARCH == alpha ]] && cpu_setting='CPU=alpha'
+
econf || die "./configure failed"
- make || die
+ make ${cpu_setting} || die
}
src_install () {