summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2003-08-01 06:40:50 +0000
committerNed Ludd <solar@gentoo.org>2003-08-01 06:40:50 +0000
commit9b63e5e1b4794657722b8ca529dc48ce9b2772c3 (patch)
tree8efb1fc13fe2530e4ccf24fe9a02320e302d2e4b /dev-libs/geoip/geoip-1.2.1.ebuild
parentThe changes in this release are as follows: This release represents a signifi... (diff)
downloadhistorical-9b63e5e1b4794657722b8ca529dc48ce9b2772c3.tar.gz
historical-9b63e5e1b4794657722b8ca529dc48ce9b2772c3.tar.bz2
historical-9b63e5e1b4794657722b8ca529dc48ce9b2772c3.zip
The changes in this release are as follows: This release represents a significant advance progression from the 0.2.0 release. It has lots more new features, making the package even more powerful.
Diffstat (limited to 'dev-libs/geoip/geoip-1.2.1.ebuild')
-rw-r--r--dev-libs/geoip/geoip-1.2.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/geoip/geoip-1.2.1.ebuild b/dev-libs/geoip/geoip-1.2.1.ebuild
new file mode 100644
index 000000000000..93e3a5e374e6
--- /dev/null
+++ b/dev-libs/geoip/geoip-1.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/geoip/geoip-1.2.1.ebuild,v 1.1 2003/08/01 06:40:42 solar Exp $
+
+inherit eutils
+
+MY_P=${P/geoip/GeoIP}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Geo-IP enables you to easily lookup countries by IP addresses, even when Reverse DNS entries don't exist.
+ The Geo-IP database contains IP Network Blocks as keys and countries as values, covering every public IP address."
+
+SRC_URI="http://www.maxmind.com/download/geoip/api/c/${MY_P}.tar.gz"
+HOMEPAGE="http://www.maxmind.com/geoip/api/c.shtml"
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+MAINTAINER="solar@gentoo.org"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-libs/zlib"
+
+src_compile() {
+ econf --enable-shared || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+}