summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-06-10 13:30:49 +0000
committerMarinus Schraal <foser@gentoo.org>2003-06-10 13:30:49 +0000
commit7b9699d815efaaa96eaf4c399a7179e2c76bd1c4 (patch)
tree71832be79be3d2f550822a85352fb2fd45d7c8b9 /dev-libs/glib/glib-2.2.2.ebuild
parentnew version 'n cleanup (diff)
downloadhistorical-7b9699d815efaaa96eaf4c399a7179e2c76bd1c4.tar.gz
historical-7b9699d815efaaa96eaf4c399a7179e2c76bd1c4.tar.bz2
historical-7b9699d815efaaa96eaf4c399a7179e2c76bd1c4.zip
new version 'n cleanup
Diffstat (limited to 'dev-libs/glib/glib-2.2.2.ebuild')
-rw-r--r--dev-libs/glib/glib-2.2.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/glib/glib-2.2.2.ebuild b/dev-libs/glib/glib-2.2.2.ebuild
new file mode 100644
index 000000000000..5336f57fc787
--- /dev/null
+++ b/dev-libs/glib/glib-2.2.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.2.2.ebuild,v 1.1 2003/06/10 13:30:40 foser Exp $
+
+inherit libtool
+
+IUSE="doc"
+S=${WORKDIR}/${P}
+DESCRIPTION="The GLib library of C routines"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.2/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+
+SLOT="2"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND=">=dev-util/pkgconfig-0.14.0
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ # Seems libtool have another wierd bug, try to fix it
+ # with a fix for nautilus, bug #4190
+ elibtoolize --reverse-deps
+
+ local myconf=""
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+
+ if [ -n "$DEBUGBUILD" ]; then
+ myconf="${myconf} --enable-debug=yes"
+ fi
+
+ econf \
+ --with-threads=posix \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ # Consider invalid UTF-8 filenames as locale-specific.
+ dodir /etc/env.d
+ echo "G_BROKEN_FILENAMES=1" > ${D}/etc/env.d/50glib2
+
+ dodoc AUTHORS ChangeLog COPYING README* INSTALL NEWS NEWS.pre-1-3
+}
+
+pkg_postinst() {
+ env-update
+}
+
+pkg_postrm() {
+ env-update
+}