summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 06:20:41 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 06:20:41 +0000
commit3bec718764ff9ac07369bd757a46bef08e73b11f (patch)
tree575bcf9af303123f19cc3ea6ca71c66455f70ae6 /dev-libs/gmp/gmp-3.1.1-r1.ebuild
parentUpdates (diff)
downloadhistorical-3bec718764ff9ac07369bd757a46bef08e73b11f.tar.gz
historical-3bec718764ff9ac07369bd757a46bef08e73b11f.tar.bz2
historical-3bec718764ff9ac07369bd757a46bef08e73b11f.zip
Updates and forgotten files
Diffstat (limited to 'dev-libs/gmp/gmp-3.1.1-r1.ebuild')
-rw-r--r--dev-libs/gmp/gmp-3.1.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/gmp/gmp-3.1.1-r1.ebuild b/dev-libs/gmp/gmp-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..3e4f06b50e2d
--- /dev/null
+++ b/dev-libs/gmp/gmp-3.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-3.1.1-r1.ebuild,v 1.1 2001/03/06 06:20:41 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/gmp/${A}
+ ftp://prep.ai.mit.edu/gnu/gmp/${A}"
+HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
+DEPEND="virtual/glibc
+ >=sys-devel/m4-1.4o"
+
+src_compile() {
+ try ./configure --prefix=/usr --infodir=/usr/share/info --host=${CHOST} \
+ --enable-mpfr --enable-mpbsd
+ try make
+}
+
+src_install() {
+
+ try make prefix=${D}/usr infodir=${D}/usr/share/info install
+
+ dodoc AUTHORS ChangeLog COPYING* NEWS README
+ dodoc doc/assembly_code doc/configuration
+ dodoc doc/isa_abi_headache doc/multiplication
+ docinto html
+ dodoc doc/*.html
+
+}
+
+
+