summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-05-04 05:54:22 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-05-04 05:54:22 +0000
commitc926c58f679eefe66daa3b3ca26cd6dc5eacacc4 (patch)
tree05a26aa94a08822f05a4ffb3ebba42761c3679a2 /dev-libs/gsl
parentfix for acl patch if NLS is disabled; blocke is sending this one upstream (diff)
downloadhistorical-c926c58f679eefe66daa3b3ca26cd6dc5eacacc4.tar.gz
historical-c926c58f679eefe66daa3b3ca26cd6dc5eacacc4.tar.bz2
historical-c926c58f679eefe66daa3b3ca26cd6dc5eacacc4.zip
updated gsl to latest version
Diffstat (limited to 'dev-libs/gsl')
-rw-r--r--dev-libs/gsl/files/digest-gsl-1.1.11
-rw-r--r--dev-libs/gsl/gsl-1.1.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-libs/gsl/files/digest-gsl-1.1.1 b/dev-libs/gsl/files/digest-gsl-1.1.1
new file mode 100644
index 000000000000..4ebba820264d
--- /dev/null
+++ b/dev-libs/gsl/files/digest-gsl-1.1.1
@@ -0,0 +1 @@
+MD5 4c7dc29e0812b045ef4d5c30d23f064a gsl-1.1.1.tar.gz 2048441
diff --git a/dev-libs/gsl/gsl-1.1.1.ebuild b/dev-libs/gsl/gsl-1.1.1.ebuild
new file mode 100644
index 000000000000..9aa97648e895
--- /dev/null
+++ b/dev-libs/gsl/gsl-1.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# /space/gentoo/cvsroot/gentoo-x86/dev-libs/gsl/gsl-1.0.ebuild,v 1.1 2002/01/12 15:24:19 verwilst Exp
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="The GNU Scientific Library"
+
+SRC_URI="http://mirrors.rcn.net/pub/sourceware/gsl/${P}.tar.gz"
+
+HOMEPAGE="http://sources.redhat.com/gsl/"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+#Avoid locking (can break parallel builds)
+ local myconf
+ myconf="--disable-libtool-lock"
+
+ ./configure --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ emake || die
+
+#Uncomment the 'make check ...' line if you want to run the test suite.
+#Note that the check.log file will be several megabytes in size.
+# make check > check.log 2>&1 || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN-PROBLEMS MACHINES
+NEWS
+
+}
+
+
+