summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-05-05 12:13:52 +0000
committerMarinus Schraal <foser@gentoo.org>2003-05-05 12:13:52 +0000
commit769e5590fb7df0d7742cc8ce89f0d41f8cc05d41 (patch)
tree9193e2af14a9eb57edcbb44ad7d49bda23660d38 /dev-libs/libIDL
parentadded x11/opengl/glu deps (diff)
downloadhistorical-769e5590fb7df0d7742cc8ce89f0d41f8cc05d41.tar.gz
historical-769e5590fb7df0d7742cc8ce89f0d41f8cc05d41.tar.bz2
historical-769e5590fb7df0d7742cc8ce89f0d41f8cc05d41.zip
new version
Diffstat (limited to 'dev-libs/libIDL')
-rw-r--r--dev-libs/libIDL/files/digest-libIDL-0.8.11
-rw-r--r--dev-libs/libIDL/libIDL-0.8.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/libIDL/files/digest-libIDL-0.8.1 b/dev-libs/libIDL/files/digest-libIDL-0.8.1
new file mode 100644
index 000000000000..f1e09466908f
--- /dev/null
+++ b/dev-libs/libIDL/files/digest-libIDL-0.8.1
@@ -0,0 +1 @@
+MD5 5e6619791a7e2b8ce4a3c75d0ccdde1d libIDL-0.8.1.tar.bz2 249929
diff --git a/dev-libs/libIDL/libIDL-0.8.1.ebuild b/dev-libs/libIDL/libIDL-0.8.1.ebuild
new file mode 100644
index 000000000000..f13e4bfa59d8
--- /dev/null
+++ b/dev-libs/libIDL/libIDL-0.8.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libIDL/libIDL-0.8.1.ebuild,v 1.1 2003/05/05 12:13:52 foser Exp $
+
+inherit gnome2
+
+# FIXME : are these artifacts and can they be removed ?
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="CORBA tree builder"
+HOMEPAGE="http://www.gnome.org"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND=">=dev-libs/glib-2
+ >=sys-devel/flex-2.5.4"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ local myconf
+
+ econf --enable-debug=yes || die
+ emake || die
+}
+
+DOCS="AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README*"
+
+SCROLLKEEPER_UPDATE="0"