summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-24 02:00:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-24 02:00:29 +0000
commitd26bee9e92f8ebcc816c69da553c7ca3dc21cc29 (patch)
tree562632ac9130a523f7ffcc37d4b7dac769a79560 /dev-libs/libaio
parent+dev-util/strace:aio (diff)
downloadhistorical-d26bee9e92f8ebcc816c69da553c7ca3dc21cc29.tar.gz
historical-d26bee9e92f8ebcc816c69da553c7ca3dc21cc29.tar.bz2
historical-d26bee9e92f8ebcc816c69da553c7ca3dc21cc29.zip
Add support for alpha/arm/hppa/ia64/m68k/s390/sh.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-libs/libaio')
-rw-r--r--dev-libs/libaio/ChangeLog8
-rw-r--r--dev-libs/libaio/Manifest11
-rw-r--r--dev-libs/libaio/files/libaio-0.3.15-more-arches.patch58
-rw-r--r--dev-libs/libaio/libaio-0.3.15.ebuild14
4 files changed, 80 insertions, 11 deletions
diff --git a/dev-libs/libaio/ChangeLog b/dev-libs/libaio/ChangeLog
index a01a2a1b7aff..ff1cc9f093a2 100644
--- a/dev-libs/libaio/ChangeLog
+++ b/dev-libs/libaio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libaio
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/ChangeLog,v 1.5 2004/06/24 23:13:35 agriffis Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/ChangeLog,v 1.6 2005/08/24 02:00:29 vapier Exp $
+
+ 24 Aug 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/libaio-0.3.15-more-arches.patch, libaio-0.3.15.ebuild:
+ Add support for alpha/arm/hppa/ia64/m68k/s390/sh.
12 Jun 2004; Ian Leitch <port001@gentoo.org> libaio-0.3.15.ebuild,
libaio-0.3.92.ebuild:
diff --git a/dev-libs/libaio/Manifest b/dev-libs/libaio/Manifest
index d1370ed2e422..ba5cf7952106 100644
--- a/dev-libs/libaio/Manifest
+++ b/dev-libs/libaio/Manifest
@@ -2,15 +2,16 @@
Hash: SHA1
MD5 08aeb8a15f772dfe8e124e6ea138ddef libaio-0.3.92.ebuild 649
-MD5 7391b2efff597ee53be37e442bf8eb7d ChangeLog 841
-MD5 2e6d77cc7c07dbe040d92109bf554e56 libaio-0.3.15.ebuild 764
+MD5 251839045af23d50b13a1db442d0a337 ChangeLog 1006
+MD5 f8bea55b299c8455c12a7f5eab95f0c4 libaio-0.3.15.ebuild 890
MD5 9ab89b277f4e93b87b8a50f7c524b0d9 files/digest-libaio-0.3.15 71
MD5 7991c55ade205cb4de301576e8b4b524 files/libaio-0.3.15-2.5-2-Makefile.patch 430
MD5 79f7b9e04e046cf3a0b7594f26eee18a files/digest-libaio-0.3.92 65
+MD5 a9c5f8c7f4b546de5e767fe79c68e7ca files/libaio-0.3.15-more-arches.patch 1315
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDC9FbgIKl8Uu19MoRAoGFAJ0fwOfOvgURe3NXWAPXmiHPFRoS/gCaA/va
-NlzYTSSGErK1Znd+WoWun8s=
-=O3rA
+iD8DBQFDC9TxgIKl8Uu19MoRAt9XAJ4/FSfKpHr5EbumH7x8dozEbR+A/wCdFQdF
+4AlcA4sXGi+bIdY3HCaNBIo=
+=56B4
-----END PGP SIGNATURE-----
diff --git a/dev-libs/libaio/files/libaio-0.3.15-more-arches.patch b/dev-libs/libaio/files/libaio-0.3.15-more-arches.patch
new file mode 100644
index 000000000000..54f2b34dd088
--- /dev/null
+++ b/dev-libs/libaio/files/libaio-0.3.15-more-arches.patch
@@ -0,0 +1,58 @@
+--- src/syscall.h
++++ src/syscall.h
+@@ -1,6 +1,7 @@
+ #ifndef AIO_SYSCALL
+ #define AIO_SYSCALL
+
++#include <errno.h>
+ #include <asm/unistd.h>
+ #undef __syscall_return
+ #ifndef __powerpc__
+@@ -19,25 +20,35 @@
+ #ifndef __NR_io_setup
+ #ifdef __s390__
+ #define __NR_io_setup 243
+-#define __NR_io_destroy 244
+-#define __NR_io_getevents 245
+-#define __NR_io_submit 246
+-#define __NR_io_cancel 247
+ #endif
+ #ifdef __i386__
+ #define __NR_io_setup 245
+-#define __NR_io_destroy 246
+-#define __NR_io_getevents 247
+-#define __NR_io_submit 248
+-#define __NR_io_cancel 249
+ #endif
+ #ifdef __x86_64__
+ #define __NR_io_setup 206
+-#define __NR_io_destroy 207
+-#define __NR_io_getevents 208
+-#define __NR_io_submit 209
+-#define __NR_io_cancel 210
+ #endif
++#ifdef __alpha__
++#define __NR_io_setup 398
++#endif
++#ifdef __hppa__
++#define __NR_io_setup 215
++#endif
++#ifdef __sh__
++#define __NR_io_setup 245
++#endif
++#ifdef __arm__
++#define __NR_io_setup 0x900000+243
++#endif
++#ifdef __ia64__
++#define __NR_io_setup 1238
++#endif
++#ifdef __m68k__
++#define __NR_io_setup 241
++#endif
++#define __NR_io_destroy __NR_io_setup + 1
++#define __NR_io_getevents __NR_io_setup + 2
++#define __NR_io_submit __NR_io_setup + 3
++#define __NR_io_cancel __NR_io_setup + 4
+ #endif
+
+ #define __NR_sys_io_setup __NR_io_setup
diff --git a/dev-libs/libaio/libaio-0.3.15.ebuild b/dev-libs/libaio/libaio-0.3.15.ebuild
index 31f310093b3c..65e6818785b4 100644
--- a/dev-libs/libaio/libaio-0.3.15.ebuild
+++ b/dev-libs/libaio/libaio-0.3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.15.ebuild,v 1.9 2005/08/24 01:45:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.15.ebuild,v 1.10 2005/08/24 02:00:29 vapier Exp $
inherit eutils
@@ -11,20 +11,26 @@ SRC_URI="http://www.kernel.org/pub/linux/kernel/people/andrea/libaio/${P}-2.5-2.
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="amd64 ~s390 ~x86"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~s390 ~sh ~x86"
IUSE=""
DEPEND=""
S=${WORKDIR}/${P}-2.5-2
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-2.5-2-Makefile.patch
+ epatch "${FILESDIR}"/${P}-more-arches.patch
+}
+
src_compile() {
- epatch ${FILESDIR}/${P}-2.5-2-Makefile.patch
make || die
}
src_install() {
make \
- prefix=${D}/usr \
+ prefix="${D}"/usr \
install || die
}