summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-09-03 13:41:15 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-09-03 13:41:15 +0000
commitabb86e8f7ed480bde294ca0f81f6efb8089f05ec (patch)
tree10e271d6ef2acf2beb52fb1f838fb0ec50fb67e6 /dev-libs/libev/libev-3.80-r1.ebuild
parentApply patch to fix remote DoS in the dedicated server, bug #239557 (diff)
downloadhistorical-abb86e8f7ed480bde294ca0f81f6efb8089f05ec.tar.gz
historical-abb86e8f7ed480bde294ca0f81f6efb8089f05ec.tar.bz2
historical-abb86e8f7ed480bde294ca0f81f6efb8089f05ec.zip
Fixed dependency, bug #283558.
Package-Manager: portage-2.1.6.13/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libev/libev-3.80-r1.ebuild')
-rw-r--r--dev-libs/libev/libev-3.80-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libev/libev-3.80-r1.ebuild b/dev-libs/libev/libev-3.80-r1.ebuild
new file mode 100644
index 000000000000..5ca110ef2ea1
--- /dev/null
+++ b/dev-libs/libev/libev-3.80-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libev/libev-3.80-r1.ebuild,v 1.1 2009/09/03 13:41:15 matsuu Exp $
+
+inherit autotools eutils
+
+MY_P="${P/0}"
+DESCRIPTION="A high-performance event loop/event model with lots of feature"
+HOMEPAGE="http://software.schmorp.de/pkg/libev.html"
+SRC_URI="http://dist.schmorp.de/libev/${MY_P}.tar.gz
+ http://dist.schmorp.de/libev/${MY_P}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+# Bug #283558
+DEPEND=">=sys-libs/glibc-2.9_p20081201"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-3.42-gentoo.patch"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc Changes README
+}