summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-16 15:33:07 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-16 15:33:07 +0000
commitb317ecfdf34bfc8aec0ac64a1571c257f18e8a7d (patch)
treedb5ade757ea0e74cc5860b4b460d31aa142d3d2f /dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
parentAdded patch from Fedora to avoid collision with libquicktime, bug #324217, th... (diff)
downloadhistorical-b317ecfdf34bfc8aec0ac64a1571c257f18e8a7d.tar.gz
historical-b317ecfdf34bfc8aec0ac64a1571c257f18e8a7d.tar.bz2
historical-b317ecfdf34bfc8aec0ac64a1571c257f18e8a7d.zip
Delete older ebuild.
Diffstat (limited to 'dev-libs/libgamin/libgamin-0.1.10-r1.ebuild')
-rw-r--r--dev-libs/libgamin/libgamin-0.1.10-r1.ebuild82
1 files changed, 0 insertions, 82 deletions
diff --git a/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild b/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
deleted file mode 100644
index 28d234a74466..000000000000
--- a/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgamin/libgamin-0.1.10-r1.ebuild,v 1.9 2009/09/25 10:51:18 flameeyes Exp $
-
-inherit autotools eutils flag-o-matic libtool python
-
-MY_PN=${PN//lib/}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Library providing the FAM File Alteration Monitor API"
-HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
-SRC_URI="http://www.gnome.org/~veillard/${MY_PN}/sources/${MY_P}.tar.gz
- mirror://gentoo/${MY_PN}-0.1.9-freebsd.patch.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug kernel_linux python"
-
-RESTRICT="test" # need gam-server
-
-RDEPEND="python? ( virtual/python )
- !app-admin/fam
- !<app-admin/gamin-0.1.10"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix compile warnings; bug #188923
- epatch "${DISTDIR}/${MY_PN}-0.1.9-freebsd.patch.bz2"
-
- # Fix collision problem due to intermediate library, upstream bug #530635
- epatch "${FILESDIR}/${P}-noinst-lib.patch"
-
- # autoconf is required as the user-cflags patch modifies configure.in
- # however, elibtoolize is also required, so when the above patch is
- # removed, replace the following call with a call to elibtoolize
- eautoreconf
-
- # disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
-}
-
-src_compile() {
- # fixes bug #225403
- #append-flags "-D_GNU_SOURCE"
-
- econf --disable-debug \
- --disable-server \
- $(use_enable kernel_linux inotify) \
- $(use_enable debug debug-api) \
- $(use_with python)
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "installation failed"
-
- dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
- dohtml doc/*
-}
-
-pkg_postinst() {
- if use python; then
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup /usr/$(get_libdir)/python*/site-packages
- fi
-}