summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-11-07 20:28:51 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-11-07 20:28:51 +0000
commit52f422a1ca639e39fb27ba76e259824a0f03793b (patch)
treeef1f0881294850f827ffee874105cb1d46c08b07 /dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild
parentdoesn't work with multilib-strict (diff)
downloadhistorical-52f422a1ca639e39fb27ba76e259824a0f03793b.tar.gz
historical-52f422a1ca639e39fb27ba76e259824a0f03793b.tar.bz2
historical-52f422a1ca639e39fb27ba76e259824a0f03793b.zip
verison bump as per bug #108677
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild
new file mode 100644
index 000000000000..9e26ee119c00
--- /dev/null
+++ b/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.2.ebuild,v 1.1 2005/11/07 20:28:51 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="general purpose crypto library based on the code used in GnuPG"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/libgcrypt/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND="dev-libs/libgpg-error"
+RDEPEND="nls? ( sys-devel/gettext )
+ dev-libs/libgpg-error"
+
+src_unpack() {
+ unpack ${A}
+ epunt_cxx
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.2.1-GNU-stack-fix.patch
+}
+
+src_compile() {
+ econf $(use_enable nls) --disable-dependency-tracking --with-pic || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
+
+ # backwards compat symlinks
+ if use ppc-macos ; then
+ dosym libgcrypt.11.dylib /usr/lib/libgcrypt.7.dylib
+ else
+ dosym libgcrypt.so.11 /usr/lib/libgcrypt.so.7
+ fi
+}