summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2011-02-23 12:08:14 +0000
committerMike Auty <ikelos@gentoo.org>2011-02-23 12:08:14 +0000
commitc8ece6c83b73e99a5797d88018873b4e48eef604 (patch)
tree2e03ca4e987e3e5726284012186f8a4bc1bc03aa /dev-libs/libnfc/libnfc-1.4.2.ebuild
parent[net-wireless/wimax-tools] Add updates from git (diff)
downloadhistorical-c8ece6c83b73e99a5797d88018873b4e48eef604.tar.gz
historical-c8ece6c83b73e99a5797d88018873b4e48eef604.tar.bz2
historical-c8ece6c83b73e99a5797d88018873b4e48eef604.zip
Version bump to 1.4.2 which has a different API and now uses proper sonaming.
Package-Manager: portage-2.2.0_alpha25/cvs/Linux i686
Diffstat (limited to 'dev-libs/libnfc/libnfc-1.4.2.ebuild')
-rw-r--r--dev-libs/libnfc/libnfc-1.4.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libnfc/libnfc-1.4.2.ebuild b/dev-libs/libnfc/libnfc-1.4.2.ebuild
new file mode 100644
index 000000000000..6a4ab4c87af0
--- /dev/null
+++ b/dev-libs/libnfc/libnfc-1.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libnfc/libnfc-1.4.2.ebuild,v 1.1 2011/02/23 12:08:14 ikelos Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Near Field Communications (NFC) library"
+HOMEPAGE="http://www.libnfc.org/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc"
+
+RDEPEND="sys-apps/pcsc-lite
+ dev-libs/libusb"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ emake || die "Failed to compile."
+ use doc && doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Failed to install properly."
+ use doc && dohtml "${S}"/doc/html/*
+}