summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-12-23 08:04:18 +0000
committerNick Hadaway <raker@gentoo.org>2002-12-23 08:04:18 +0000
commitb3192286d5732098cc0474c2ed7e835fcf1530d9 (patch)
tree97c529ec62f3f705cb86e79697124969c590f410 /dev-libs/libusb/libusb-0.1.7.ebuild
parentVersion bump. (diff)
downloadhistorical-b3192286d5732098cc0474c2ed7e835fcf1530d9.tar.gz
historical-b3192286d5732098cc0474c2ed7e835fcf1530d9.tar.bz2
historical-b3192286d5732098cc0474c2ed7e835fcf1530d9.zip
Version bump. Added DEBUGBUILD and doc use variable related code.
Please comment on bug #11512.
Diffstat (limited to 'dev-libs/libusb/libusb-0.1.7.ebuild')
-rw-r--r--dev-libs/libusb/libusb-0.1.7.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/libusb/libusb-0.1.7.ebuild b/dev-libs/libusb/libusb-0.1.7.ebuild
new file mode 100644
index 000000000000..e194b3e69edc
--- /dev/null
+++ b/dev-libs/libusb/libusb-0.1.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libusb/libusb-0.1.7.ebuild,v 1.1 2002/12/23 08:04:18 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Userspace access to USB devices"
+SRC_URI="mirror://sourceforge/libusb/${P}.tar.gz"
+HOMEPAGE="http://libusb.sourceforge.net"
+
+DEPEND="virtual/glibc
+ doc? ( app-text/openjade )"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+src_compile() {
+
+ local myconf
+
+ use doc \
+ && myconf="--enable-build-docs" \
+ || myconf="--disable-build-docs"
+
+ [ -n "${DEBUGBUILD}" ] \
+ && myconf="${myconf} --enable-debug=all" \
+ || myconf="${myconf} --disable-debug"
+
+ econf ${myconf} || die
+
+ make || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS NEWS README
+
+ cd doc/html
+ use doc && dohtml *.html
+
+}