summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-12-27 22:24:14 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-12-27 22:24:14 +0000
commit048f33bf098aa6a184b517558710673863a959a9 (patch)
treecc149265d6039fd15867f373da476987e3c42110 /dev-libs/libyaml/libyaml-0.1.4.ebuild
parentppc stable (bug 371769) (diff)
downloadhistorical-048f33bf098aa6a184b517558710673863a959a9.tar.gz
historical-048f33bf098aa6a184b517558710673863a959a9.tar.bz2
historical-048f33bf098aa6a184b517558710673863a959a9.zip
version bump. switching to EAPI=4, adding USE=static-libs.
Package-Manager: portage-2.2.0_alpha81/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/libyaml/libyaml-0.1.4.ebuild')
-rw-r--r--dev-libs/libyaml/libyaml-0.1.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-libs/libyaml/libyaml-0.1.4.ebuild b/dev-libs/libyaml/libyaml-0.1.4.ebuild
new file mode 100644
index 000000000000..20de11fbf079
--- /dev/null
+++ b/dev-libs/libyaml/libyaml-0.1.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libyaml/libyaml-0.1.4.ebuild,v 1.1 2011/12/27 22:24:14 sbriesen Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_P="${P/lib}"
+
+DESCRIPTION="YAML 1.1 parser and emitter written in C"
+HOMEPAGE="http://pyyaml.org/wiki/LibYAML"
+SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="doc examples test static-libs"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="README"
+
+src_prepare() {
+ # conditionally remove tests
+ if use test; then
+ sed -i -e 's: tests::g' Makefile*
+ fi
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/.
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples
+ doins tests/example-*.c
+ fi
+}