summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-11-17 04:45:45 +0000
committerNaohiro Aota <naota@gentoo.org>2011-11-17 04:45:45 +0000
commitea89b1c9d72744a95c95125311d660f8f1d01b88 (patch)
treefbb49969a9db2b8641704df4d4e544e606eed5b8 /dev-libs/newt/files
parentin-place update to support dev-lang/spidermonkey-1.8.5 for bug 376993 (diff)
downloadhistorical-ea89b1c9d72744a95c95125311d660f8f1d01b88.tar.gz
historical-ea89b1c9d72744a95c95125311d660f8f1d01b88.tar.bz2
historical-ea89b1c9d72744a95c95125311d660f8f1d01b88.zip
Version bumped
Package-Manager: portage-2.2.0_alpha73/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/newt/files')
-rw-r--r--dev-libs/newt/files/newt-0.52.13-gold.patch12
-rw-r--r--dev-libs/newt/files/newt-0.52.13-python.patch32
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-libs/newt/files/newt-0.52.13-gold.patch b/dev-libs/newt/files/newt-0.52.13-gold.patch
new file mode 100644
index 000000000000..5781dbf550f4
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.13-gold.patch
@@ -0,0 +1,12 @@
+--- configure.ac~ 2011-11-09 23:50:21.000000000 +0900
++++ configure.ac 2011-11-09 23:54:54.139482817 +0900
+@@ -19,7 +19,8 @@
+ AC_MSG_CHECKING([for GNU ld])
+ LD=`$CC -print-prog-name=ld 2>&5`
+
+-if test `$LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld"` = 0; then
++if test `$LD -v 2>&1 | $ac_cv_path_GREP -c "GNU ld"` = 0 -a \
++ test `$LD -v 2>&1 | $ac_cv_path_GREP -c "GNU gold"` = 0; then
+ # Not
+ GNU_LD=""
+ AC_MSG_RESULT([no])
diff --git a/dev-libs/newt/files/newt-0.52.13-python.patch b/dev-libs/newt/files/newt-0.52.13-python.patch
new file mode 100644
index 000000000000..0487186147d8
--- /dev/null
+++ b/dev-libs/newt/files/newt-0.52.13-python.patch
@@ -0,0 +1,32 @@
+diff --git a/configure.ac b/configure.ac
+index b972805..1fe4bdf 100644
+--- a/configure.ac (revision 34e56d12931a25222d7debb22f95bb2f9fa696a0)
++++ b/configure.ac (revision 49d37f0cc7121a8386e4a8f21e5e0f7b614922b1)
+@@ -60,5 +60,5 @@
+ PYTHONVERS=
+ else
+- PYTHONVERS=$(ls /usr/include/python*/Python.h 2> /dev/null | sed "s|/usr/include/||g"| sed "s|/Python.h||g" 2> /dev/null)
++ PYTHONVERS=$(ls /usr/include/python2.*/Python.h 2> /dev/null | sed 's|/usr/include/\([[^/]]*\)/Python.h|\1|g' | tr '\n' ' ')
+ AC_MSG_RESULT([$PYTHONVERS])
+ fi
+diff --git a/Makefile.in b/Makefile.in
+index a448c5f..f9bbe1f 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -79,11 +79,11 @@ showkey: showkey.o $(LIBNEWT)
+ _snackmodule.so: snackmodule.c $(LIBNEWTSH)
+ [ -n "$(PYTHONVERS)" ] && for ver in $(PYTHONVERS) ; do \
+ mkdir -p $$ver ;\
+- PCFLAGS=`$$ver-config --cflags`; \
+- PIFLAGS=`$$ver-config --includes`; \
+- PLDFLAGS=`$$ver-config --ldflags`; \
+- PLFLAGS=`$$ver-config --libs`; \
+- $(CC) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -o $$ver/snackmodule.o snackmodule.c ;\
++ PCFLAGS=`python-config-$${ver#python} --cflags`; \
++ PIFLAGS=`python-config-$${ver#python} --includes`; \
++ PLDFLAGS=`python-config-$${ver#python} --ldflags`; \
++ PLFLAGS=`python-config-$${ver#python} --libs`; \
++ $(CC) $(CPPFLAGS) $$PIFLAGS $$PCFLAGS -c -fPIC -o $$ver/snackmodule.o snackmodule.c ;\
+ $(CC) --shared $$PLDFLAGS $$PLFLAGS $(LDFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L. -lnewt $(LIBS);\
+ done || :
+ touch $@