summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-02-27 10:14:49 +0000
committerFabian Groffen <grobian@gentoo.org>2011-02-27 10:14:49 +0000
commiteef115ac61394fcb843c595f53d78f3048832cd7 (patch)
treec523fbeca58a9ddb83ff9b810f4d12713ff8570f /dev-libs/nspr/nspr-4.8.7.ebuild
parentMarked ~ppc64 wrt #351526 (diff)
downloadhistorical-eef115ac61394fcb843c595f53d78f3048832cd7.tar.gz
historical-eef115ac61394fcb843c595f53d78f3048832cd7.tar.bz2
historical-eef115ac61394fcb843c595f53d78f3048832cd7.zip
Change from file to scanelf/scanmacho, such that detection of platform bitwidth is easier and less prone to changes across systems and output of file, bug #354483
Package-Manager: portage-2.2.01.18036-prefix/cvs/Darwin powerpc
Diffstat (limited to 'dev-libs/nspr/nspr-4.8.7.ebuild')
-rw-r--r--dev-libs/nspr/nspr-4.8.7.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-libs/nspr/nspr-4.8.7.ebuild b/dev-libs/nspr/nspr-4.8.7.ebuild
index 9ac6d0fecd94..8d58116a5296 100644
--- a/dev-libs/nspr/nspr-4.8.7.ebuild
+++ b/dev-libs/nspr/nspr-4.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.7.ebuild,v 1.1 2011/01/14 13:37:10 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.8.7.ebuild,v 1.2 2011/02/27 10:14:49 grobian Exp $
EAPI=3
@@ -43,9 +43,9 @@ src_configure() {
echo > "${T}"/test.c
$(tc-getCC) -c "${T}"/test.c -o "${T}"/test.o
- case $(file "${T}"/test.o) in
- *64-bit*|*ppc64*|*x86_64*) myconf="${myconf} --enable-64bit";;
- *32-bit*|*ppc*|*i386*|*"RISC System/6000"*) ;;
+ case $(scanelf -BF'%M' "${T}"/test.o)$(scanmacho -BF'%M' "${T}"/test.o) in
+ ELFCLASS64*|POWERPC64*|X86_64*) myconf="${myconf} --enable-64bit";;
+ ELFCLASS32*|POWERPC*|I386*|ARM*) ;;
*) die "Failed to detect whether your arch is 64bits or 32bits, disable distcc if you're using it, please";;
esac