summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-21 05:36:55 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-21 05:36:55 +0000
commit6c305aea08c745b45859c89dd3422b46762fcfe2 (patch)
tree77b7d5983abf6ee4e37e86cc0a69b8ac8f24b5d4 /dev-libs/openssl/files
parentold (diff)
downloadhistorical-6c305aea08c745b45859c89dd3422b46762fcfe2.tar.gz
historical-6c305aea08c745b45859c89dd3422b46762fcfe2.tar.bz2
historical-6c305aea08c745b45859c89dd3422b46762fcfe2.zip
Respect LDFLAGS #181438 by Arfrever Frehtes Taifersar Arahesis and add fix from upstream for PKCS12 troubles #224843 by Per Pomsel.
Package-Manager: portage-2.2_pre8/cvs/Linux 2.6.25 x86_64
Diffstat (limited to 'dev-libs/openssl/files')
-rw-r--r--dev-libs/openssl/files/openssl-0.9.8h-ldflags.patch25
-rw-r--r--dev-libs/openssl/files/openssl-0.9.8h-pkcs12.patch21
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/openssl/files/openssl-0.9.8h-ldflags.patch b/dev-libs/openssl/files/openssl-0.9.8h-ldflags.patch
new file mode 100644
index 000000000000..4658c85ebce1
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-0.9.8h-ldflags.patch
@@ -0,0 +1,25 @@
+http://bugs.gentoo.org/181438
+
+make sure we respect LDFLAGS
+
+--- openssl-0.9.8h/Makefile
++++ openssl-0.9.8h/Makefile
+@@ -180,6 +181,7 @@
+ MAKEDEPEND='$$$${TOP}/util/domd $$$${TOP} -MD ${MAKEDEPPROG}' \
+ DEPFLAG='-DOPENSSL_NO_DEPRECATED ${DEPFLAG}' \
+ MAKEDEPPROG='${MAKEDEPPROG}' \
++ LDFLAGS='${LDFLAGS}' \
+ SHARED_LDFLAGS='${SHARED_LDFLAGS}' \
+ KRB5_INCLUDES='${KRB5_INCLUDES}' LIBKRB5='${LIBKRB5}' \
+ EXE_EXT='${EXE_EXT}' SHARED_LIBS='${SHARED_LIBS}' \
+--- openssl-0.9.8h/Makefile.shared
++++ openssl-0.9.8h/Makefile.shared
+@@ -153,7 +153,7 @@
+ NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
+ SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
+
+-DO_GNU_APP=LDFLAGS="$(CFLAGS) -Wl,-rpath,$(LIBRPATH)"
++DO_GNU_APP=LDFLAGS="$(LDFLAGS) $(CFLAGS) -Wl,-rpath,$(LIBRPATH)"
+
+ #This is rather special. It's a special target with which one can link
+ #applications without bothering with any features that have anything to
diff --git a/dev-libs/openssl/files/openssl-0.9.8h-pkcs12.patch b/dev-libs/openssl/files/openssl-0.9.8h-pkcs12.patch
new file mode 100644
index 000000000000..bec63f1da33a
--- /dev/null
+++ b/dev-libs/openssl/files/openssl-0.9.8h-pkcs12.patch
@@ -0,0 +1,21 @@
+fix from upstream
+
+http://bugs.gentoo.org/224843
+
+Index: crypto/x509/x509_att.c
+===================================================================
+RCS file: /usr/local/src/openssl/CVSROOT/openssl/crypto/x509/x509_att.c,v
+retrieving revision 1.8.2.2
+retrieving revision 1.8.2.3
+diff -u -p -r1.8.2.2 -r1.8.2.3
+--- crypto/x509/x509_att.c 2 Apr 2008 11:11:51 -0000 1.8.2.2
++++ crypto/x509/x509_att.c 30 May 2008 10:57:13 -0000 1.8.2.3
+@@ -303,7 +303,7 @@ int X509_ATTRIBUTE_set1_data(X509_ATTRIB
+ }
+ if(!(attr->value.set = sk_ASN1_TYPE_new_null())) goto err;
+ if(!(ttmp = ASN1_TYPE_new())) goto err;
+- if (len == -1)
++ if ((len == -1) && !(attrtype & MBSTRING_FLAG))
+ {
+ if (!ASN1_TYPE_set1(ttmp, attrtype, data))
+ goto err;