summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-17 21:44:57 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-17 21:44:57 +0000
commitd982241f04149f15f29ea49d7511ab71e740e51d (patch)
treeb709be6f5f0a544e0f8c60e5b481f1a5bd6bdb66 /dev-libs/pilot-link
parent-fPIC addition (diff)
downloadhistorical-d982241f04149f15f29ea49d7511ab71e740e51d.tar.gz
historical-d982241f04149f15f29ea49d7511ab71e740e51d.tar.bz2
historical-d982241f04149f15f29ea49d7511ab71e740e51d.zip
perl + java work now, thanks Nicholas Wourms <nwourms@netscape.net>
Diffstat (limited to 'dev-libs/pilot-link')
-rw-r--r--dev-libs/pilot-link/ChangeLog9
-rw-r--r--dev-libs/pilot-link/files/digest-pilot-link-0.11.5-r11
-rw-r--r--dev-libs/pilot-link/files/perlpatch.diff19
-rw-r--r--dev-libs/pilot-link/pilot-link-0.11.5-r1.ebuild100
4 files changed, 128 insertions, 1 deletions
diff --git a/dev-libs/pilot-link/ChangeLog b/dev-libs/pilot-link/ChangeLog
index d5c78f9f9562..8a79024b9b0f 100644
--- a/dev-libs/pilot-link/ChangeLog
+++ b/dev-libs/pilot-link/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/pilot-link
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/ChangeLog,v 1.10 2002/11/03 21:11:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/ChangeLog,v 1.11 2002/11/17 21:44:57 vapier Exp $
+
+*pilot-link-0.11.5-r1 (17 Nov 2002)
+
+ 17 Nov 2002; Mike Frysinger <vapier@gentoo.org> :
+ Huge thanks goes out to Nicholas Wourms <nwourms@netscape.net>.
+ He sent me a patch to make the perl module compile/install via
+ perl-module eclass and pointed at emake as the reason java dies.
*pilot-link-0.11.5 (28 Oct 2002)
diff --git a/dev-libs/pilot-link/files/digest-pilot-link-0.11.5-r1 b/dev-libs/pilot-link/files/digest-pilot-link-0.11.5-r1
new file mode 100644
index 000000000000..9e6b741ec15a
--- /dev/null
+++ b/dev-libs/pilot-link/files/digest-pilot-link-0.11.5-r1
@@ -0,0 +1 @@
+MD5 f7e9d73959d9e1d998837e93d03c58e7 pilot-link-0.11.5.tar.bz2 635370
diff --git a/dev-libs/pilot-link/files/perlpatch.diff b/dev-libs/pilot-link/files/perlpatch.diff
new file mode 100644
index 000000000000..73ad52479b87
--- /dev/null
+++ b/dev-libs/pilot-link/files/perlpatch.diff
@@ -0,0 +1,19 @@
+diff -Naurp pilot-link-0.11.5.orig/bindings/Makefile.in pilot-link-0.11.5/bindings/Makefile.in
+--- pilot-link-0.11.5.orig/bindings/Makefile.in 2002-09-28 15:19:45.000000000 -0400
++++ pilot-link-0.11.5/bindings/Makefile.in 2002-11-17 11:41:24.000000000 -0500
+@@ -368,11 +368,11 @@ python-clean: Python/setup.py
+ Perl/Makefile: Perl/Makefile.PL
+ cd Perl && $(PERL) Makefile.PL INSTALLDIRS=vendor
+
+-perl-build: Perl/Makefile
+- cd Perl && $(MAKE) PREFIX=$(DESTDIR)$(prefix)
++perl-build:
++# cd Perl && $(MAKE) PREFIX=$(DESTDIR)$(prefix)
+
+-perl-install: perl-build
+- cd Perl && $(MAKE) install
++perl-install:
++# cd Perl && $(MAKE) install
+
+ perl-uninstall: Perl/Makefile
+ cd Perl && $(MAKE) uninstall
diff --git a/dev-libs/pilot-link/pilot-link-0.11.5-r1.ebuild b/dev-libs/pilot-link/pilot-link-0.11.5-r1.ebuild
new file mode 100644
index 000000000000..71a41fb32fb2
--- /dev/null
+++ b/dev-libs/pilot-link/pilot-link-0.11.5-r1.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/pilot-link/pilot-link-0.11.5-r1.ebuild,v 1.1 2002/11/17 21:44:57 vapier Exp $
+
+inherit perl-module
+
+DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
+
+SRC_URI="http://pilot-link.org/source/${P}.tar.bz2"
+HOMEPAGE="http://www.pilot-link.org/"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+IUSE="perl java tcltk python pic png readline"
+
+DEPEND="virtual/glibc
+ sys-libs/ncurses
+ perl? ( sys-devel/perl )
+ java? ( virtual/jre )
+ tcltk? ( dev-lang/tcl dev-tcltk/itcl dev-lang/tk )
+ python? ( dev-lang/python )
+ png? ( media-libs/libpng )
+ readline? ( sys-libs/readline )"
+
+src_compile() {
+# Fix up perl bindings to install the "Gentoo" way
+# http://gnu-designs.com/bugs/view_bug_page.php?f_id=259
+ use perl && patch -p1 < ${FILESDIR}/perlpatch.diff
+
+ local myconf="--with-gnu-ld --includedir=/usr/include/libpisock"
+
+ use pic && myconf="${myconf} --with-pic"
+
+ use java \
+ && myconf="${myconf} --with-java=yes" \
+ || myconf="${myconf} --with-java=no"
+
+ use perl \
+ && myconf="${myconf} --with-perl=yes" \
+ || myconf="${myconf} --with-perl=no"
+
+ use python \
+ && myconf="${myconf} --with-python=yes" \
+ || myconf="${myconf} --with-python=no"
+
+ use tcltk \
+ && myconf="${myconf} --with-tcl=yes --with-itcl=yes --with-tk=yes" \
+ || myconf="${myconf} --with-tcl=no --with-itcl=no --with-tk=no"
+
+ use png && myconf="${myconf} --with-libpng=/usr"
+
+ use readline \
+ && myconf="${myconf} --with-readline=yes" \
+ || myconf="${myconf} --with-readline=no"
+
+# make configure script:
+# - look for ncurses rather than termcap
+# http://gnu-designs.com/bugs/view_bug_page.php?f_id=381
+# - link png check with more libraries
+# http://gnu-designs.com/bugs/view_bug_page.php?f_id=380
+ cp configure configure.old
+ sed -e 's:-ltermcap:-lncurses:' \
+ -e 's:-lpng:-lpng -lz -lstdc++:' \
+ configure.old > configure
+
+# fix pilot-debug.c
+# http://gnu-designs.com/bugs/view_bug_page.php?f_id=129
+ cp src/pilot-debug.c src/pilot-debug.c.old
+ sed -e 's:TCL_MINOR_VERSION <4:TCL_MINOR_VERSION <3:' \
+ src/pilot-debug.c.old > src/pilot-debug.c
+
+ econf ${myconf}
+
+# so python doesnt violate sandbox
+# http://gnu-designs.com/bugs/view_bug_page.php?f_id=382
+ cp bindings/Makefile bindings/Makefile.old
+ sed -e 's:--prefix=$(prefix):--prefix=$(prefix) --root=$(DESTDIR):' \
+ bindings/Makefile.old > bindings/Makefile
+
+# java fails w/emake
+ make || die
+
+ if [ `use perl` ] ; then
+ cd ${S}/bindings/Perl
+ perl-module_src_prep
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc ChangeLog README doc/README* doc/TODO NEWS AUTHORS
+
+ if [ `use perl` ] ; then
+ cd ${S}/bindings/Perl
+ perl-module_src_install
+ fi
+}