summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-05-21 19:58:32 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-05-21 19:58:32 +0000
commit90f0a1666d60164dc77b2e62a0b0aefb85192234 (patch)
tree902c8cf1898d9d2777e874bb9729fb8f6178db71 /dev-libs/qoauth/qoauth-1.0.1.ebuild
parentinherit eutils for make_desktop_entry (diff)
downloadhistorical-90f0a1666d60164dc77b2e62a0b0aefb85192234.tar.gz
historical-90f0a1666d60164dc77b2e62a0b0aefb85192234.tar.bz2
historical-90f0a1666d60164dc77b2e62a0b0aefb85192234.zip
Use more qt4-r2 eclass features.
Package-Manager: portage-2.2.0_alpha107/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/qoauth/qoauth-1.0.1.ebuild')
-rw-r--r--dev-libs/qoauth/qoauth-1.0.1.ebuild26
1 files changed, 16 insertions, 10 deletions
diff --git a/dev-libs/qoauth/qoauth-1.0.1.ebuild b/dev-libs/qoauth/qoauth-1.0.1.ebuild
index 87f5fb3451dc..fdd94ad87e6f 100644
--- a/dev-libs/qoauth/qoauth-1.0.1.ebuild
+++ b/dev-libs/qoauth/qoauth-1.0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/qoauth-1.0.1.ebuild,v 1.7 2012/02/18 17:33:43 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qoauth/qoauth-1.0.1.ebuild,v 1.8 2012/05/21 19:58:32 pesa Exp $
-EAPI="2"
+EAPI=2
inherit qt4-r2
@@ -18,16 +18,23 @@ IUSE="debug doc static-libs test"
COMMON_DEPEND="app-crypt/qca:2[debug?]"
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )
- test? ( x11-libs/qt-test )"
+ test? ( x11-libs/qt-test )
+"
RDEPEND="${COMMON_DEPEND}
- app-crypt/qca-ossl:2[debug?]"
+ app-crypt/qca-ossl:2[debug?]
+"
-S="${WORKDIR}/${P}-src"
+S=${WORKDIR}/${P}-src
+
+DOCS="README CHANGELOG"
+PATCHES=(
+ # disable functional tests that require network connection
+ # and rely on 3rd party external server (bug #341267)
+ "${FILESDIR}/${P}-disable-ft.patch"
+)
src_prepare() {
- # disable functional tests that require network connection and rely
- # on 3rd party external server (bug #341267)
- epatch "${FILESDIR}/${P}-disable-ft.patch"
+ qt4-r2_src_prepare
if ! use test; then
sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
@@ -49,8 +56,7 @@ src_compile() {
}
src_install() {
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- dodoc README CHANGELOG || die "dodoc failed"
+ qt4-r2_src_install
if use static-libs; then
dolib.a "${S}/lib/lib${PN}.a" || die "dolib failed"