summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2003-08-25 20:28:27 +0000
committerStuart Herbert <stuart@gentoo.org>2003-08-25 20:28:27 +0000
commit2b8c9f7479f2cbd22f1912999f1a464275de0ee1 (patch)
treed53b1672d6b2102a3029e8a3c8708a7ef3e7d291 /dev-libs/skalibs/skalibs-0.30.ebuild
parentInitial import (diff)
downloadhistorical-2b8c9f7479f2cbd22f1912999f1a464275de0ee1.tar.gz
historical-2b8c9f7479f2cbd22f1912999f1a464275de0ee1.tar.bz2
historical-2b8c9f7479f2cbd22f1912999f1a464275de0ee1.zip
Initial import
Diffstat (limited to 'dev-libs/skalibs/skalibs-0.30.ebuild')
-rw-r--r--dev-libs/skalibs/skalibs-0.30.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/skalibs/skalibs-0.30.ebuild b/dev-libs/skalibs/skalibs-0.30.ebuild
new file mode 100644
index 000000000000..7cd57164d746
--- /dev/null
+++ b/dev-libs/skalibs/skalibs-0.30.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/skalibs/skalibs-0.30.ebuild,v 1.1 2003/08/25 20:28:19 stuart Exp $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+DESCRIPTION="common libraries for skarnet.org packages"
+HOMEPAGE="http://www.skarnet.org/software/skalibs/"
+SRC_URI="http://www.skarnet.org/software/skalibs/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-libs/dietlibc"
+#RDEPEND=""
+
+MY_INSTALL="/package/prog/skalibs/"
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
+# if you omit this line.
+S=${WORKDIR}/prog/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/headers
+ patch gccattributes.h < ${FILESDIR}/skalibs-0.30-gccattributes.h.patch
+}
+
+src_compile() {
+ package/install
+}
+
+src_install() {
+ insinto ${MY_INSTALL}/library
+ doins library/*.a
+ insinto ${MY_INSTALL}/sysdeps
+ doins sysdeps/*
+ insinto ${MY_INSTALL}/include
+ doins include/*
+}