summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-02-28 14:28:48 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-02-28 14:28:48 +0000
commitc809a94a65c0f2cc6ae2f976a2e6218c22b3ca45 (patch)
tree0d49f0dfbb397a33fc92eb3dd989c16cb621632b /dev-libs/tc2-modules/tc2-modules-0.5.2.ebuild
parentAdded to ~ppc (diff)
downloadhistorical-c809a94a65c0f2cc6ae2f976a2e6218c22b3ca45.tar.gz
historical-c809a94a65c0f2cc6ae2f976a2e6218c22b3ca45.tar.bz2
historical-c809a94a65c0f2cc6ae2f976a2e6218c22b3ca45.zip
version bump
Diffstat (limited to 'dev-libs/tc2-modules/tc2-modules-0.5.2.ebuild')
-rw-r--r--dev-libs/tc2-modules/tc2-modules-0.5.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/tc2-modules/tc2-modules-0.5.2.ebuild b/dev-libs/tc2-modules/tc2-modules-0.5.2.ebuild
new file mode 100644
index 000000000000..0e4fba91eb32
--- /dev/null
+++ b/dev-libs/tc2-modules/tc2-modules-0.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+IUSE="static"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Modules for tc2."
+HOMEPAGE="http://tc2.sourceforge.net"
+SRC_URI="mirror://sourceforge/tc2/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="OpenSoftware"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64"
+
+DEPEND=">=dev-libs/tc2-0.5.6"
+
+
+src_compile() {
+ local myconf
+ myconf="--with-gnu-ld"
+ use static && myconf="${myconf} --enable-static"
+
+ econf ${myconf} || die "configure failed"
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}