summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-12 14:13:01 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-05-12 14:13:01 +0000
commit5597e62016f7e8f929a4a2e26590056393e78068 (patch)
tree1f46e91121a1480e5ecc731080f5cbae905ccbae /dev-libs/udis86/udis86-1.7.ebuild
parentnew snapshot (diff)
downloadhistorical-5597e62016f7e8f929a4a2e26590056393e78068.tar.gz
historical-5597e62016f7e8f929a4a2e26590056393e78068.tar.bz2
historical-5597e62016f7e8f929a4a2e26590056393e78068.zip
Don't fail tests if dev-lang/yasm is not installed, bug #318805
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/udis86/udis86-1.7.ebuild')
-rw-r--r--dev-libs/udis86/udis86-1.7.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-libs/udis86/udis86-1.7.ebuild b/dev-libs/udis86/udis86-1.7.ebuild
index 1dce723b6c99..86ba546a4b1a 100644
--- a/dev-libs/udis86/udis86-1.7.ebuild
+++ b/dev-libs/udis86/udis86-1.7.ebuild
@@ -1,6 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/udis86/udis86-1.7.ebuild,v 1.6 2010/05/11 21:02:36 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/udis86/udis86-1.7.ebuild,v 1.7 2010/05/12 14:13:00 chithanh Exp $
+
+EAPI=3
+inherit autotools
DESCRIPTION="Disassembler library for the x86/-64 architecture sets."
HOMEPAGE="http://udis86.sourceforge.net/"
@@ -12,11 +15,18 @@ KEYWORDS="~amd64 ~hppa ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
DEPEND="test? (
- x86? ( dev-lang/yasm )
- amd64? ( dev-lang/yasm )
+ amd64? ( dev-lang/yasm )
+ x86? ( dev-lang/yasm )
+ x86-fbsd? ( dev-lang/yasm )
)"
RDEPEND=""
+src_prepare() {
+ # Don't fail tests if dev-lang/yasm is not installed, bug #318805
+ epatch "${FILESDIR}"/${P}-yasm.patch
+ eautoreconf
+}
+
src_install() {
emake docdir="/usr/share/doc/${PF}/" DESTDIR="${D}" install || die "emake install failed"
}