summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-08-29 11:47:00 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-08-29 11:47:00 +0000
commitab0266fa67dc627548a8c9fdd122a38bb5436793 (patch)
treeab4e1808242093bdd2d8c1f013fe38769c3b3751 /dev-libs/xqilla/xqilla-2.2.4.ebuild
parentRemove old versions. (diff)
downloadhistorical-ab0266fa67dc627548a8c9fdd122a38bb5436793.tar.gz
historical-ab0266fa67dc627548a8c9fdd122a38bb5436793.tar.bz2
historical-ab0266fa67dc627548a8c9fdd122a38bb5436793.zip
Version bump (bug #319753).
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/xqilla/xqilla-2.2.4.ebuild')
-rw-r--r--dev-libs/xqilla/xqilla-2.2.4.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-libs/xqilla/xqilla-2.2.4.ebuild b/dev-libs/xqilla/xqilla-2.2.4.ebuild
new file mode 100644
index 000000000000..cf10fb921cfc
--- /dev/null
+++ b/dev-libs/xqilla/xqilla-2.2.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xqilla/xqilla-2.2.4.ebuild,v 1.1 2010/08/29 11:47:00 dev-zero Exp $
+
+EAPI="2"
+inherit autotools eutils
+
+MY_P="XQilla-${PV}"
+
+DESCRIPTION="An XQuery and XPath 2 library and command line utility written in C++."
+HOMEPAGE="http://xqilla.sourceforge.net/HomePage"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples faxpp htmltidy"
+
+# XQilla bundles two libraries:
+# - mapm, heavily patched
+# - yajl, moderately patched
+# There's currently no way to unbundle those
+
+RDEPEND=">=dev-libs/xerces-c-3.1.0
+ faxpp? ( dev-libs/faxpp )
+ htmltidy? ( app-text/htmltidy )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # respect our LDFLAGS and don't add an rpath for the xerces-c lib
+ # since that is in the default LDPATH anyway and the binaries
+ # may need relinking at install-time because they temporary use
+ # already installed libraries
+ epatch "${FILESDIR}/${PV}-respect-ldflags-no-rpath.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-xerces=/usr \
+ $(use_enable debug) \
+ $(use_with htmltidy tidy) \
+ $(use_with faxpp faxpp /usr)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake docs || die "emake docs failed"
+ emake devdocs || die "emake devdocs failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake docs failed"
+
+ dodoc ChangeLog TODO
+
+ if use doc; then
+ cd docs
+ dohtml -r dev-api dom3-api simple-api
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${S}"/src/samples/*
+ fi
+}