summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-10-10 09:36:36 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-10-10 09:36:36 +0000
commit30a1a45824907267e24a4971afa2198448e0a670 (patch)
tree5c85a81b07b37304f3684466bd553976e084e68c /dev-libs
parentClosing #30657 (diff)
downloadhistorical-30a1a45824907267e24a4971afa2198448e0a670.tar.gz
historical-30a1a45824907267e24a4971afa2198448e0a670.tar.bz2
historical-30a1a45824907267e24a4971afa2198448e0a670.zip
Closing #30657
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/Manifest4
-rw-r--r--dev-libs/openssl/files/digest-openssl-0.9.6k-r11
-rw-r--r--dev-libs/openssl/openssl-0.9.6k-r1.ebuild105
3 files changed, 108 insertions, 2 deletions
diff --git a/dev-libs/openssl/Manifest b/dev-libs/openssl/Manifest
index aa15389f0402..b20dcfcb14d1 100644
--- a/dev-libs/openssl/Manifest
+++ b/dev-libs/openssl/Manifest
@@ -2,8 +2,8 @@ MD5 6b359ad3ed7fdab3951227d9f5018e15 openssl-0.9.7c.ebuild 4792
MD5 69ad81d01cbeb155e1238e208018f7bd openssl-0.9.6k.ebuild 2601
MD5 37236013e0d26d43c6bff35a8a48e8ec metadata.xml 220
MD5 f110bafc5ab22d7c5529adddca5c9312 openssl-0.9.7b-r3.ebuild 4790
-MD5 a51318d7bbb43f30206b5f782359dd97 ChangeLog 9186
-MD5 4227b7a2ac2c21b17f0c0c51dc5d6014 openssl-0.9.6k-r1.ebuild 3133
+MD5 fcc1fb6e625d77ba2445069374228aac ChangeLog 9185
+MD5 3b98a51d6ad3d2f89f0dfb772b17bb77 openssl-0.9.6k-r1.ebuild 3136
MD5 9ec1d0cf71fb5fab0dfd0d8b409fcc9c openssl-0.9.7b.ebuild 3326
MD5 e4af813471d470d25fb77231d324ad1c files/digest-openssl-0.9.6k 67
MD5 a5a379391dfaaef98e4fe4198ff2ed2c files/openssl-0.9.6i-blinding.patch 1717
diff --git a/dev-libs/openssl/files/digest-openssl-0.9.6k-r1 b/dev-libs/openssl/files/digest-openssl-0.9.6k-r1
new file mode 100644
index 000000000000..86e5198e9d5b
--- /dev/null
+++ b/dev-libs/openssl/files/digest-openssl-0.9.6k-r1
@@ -0,0 +1 @@
+MD5 dee92f648a02e4a7db0507ab3d0769c6 openssl-0.9.6k.tar.gz 2183608
diff --git a/dev-libs/openssl/openssl-0.9.6k-r1.ebuild b/dev-libs/openssl/openssl-0.9.6k-r1.ebuild
new file mode 100644
index 000000000000..cbd121015671
--- /dev/null
+++ b/dev-libs/openssl/openssl-0.9.6k-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/openssl/openssl-0.9.6k-r1.ebuild,v 1.1 2003/10/10 09:36:25 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
+SRC_URI="mirror://openssl/source/${P}.tar.gz"
+HOMEPAGE="http://www.openssl.org/"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} >=dev-lang/perl-5"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~mips ~hppa ~arm"
+IUSE=""
+
+if [ "$PROFILE_ARCH" = "sparc" -a "`uname -m`" = "sparc64" ]; then
+ SSH_TARGET="linux-sparcv8"
+fi
+
+if [ "`uname -m`" = "parisc64" ]; then
+ SSH_TARGET="linux-parisc"
+fi
+
+case $CHOST in
+ alphaev56*|alphaev6*) SSH_TARGET="linux-alpha+bwx-${CC:-gcc}" ;;
+ alpha*) SSH_TARGET="linux-alpha-${CC:-gcc}" ;;
+esac
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ epatch ${FILESDIR}/${PN}-0.9.6i-gentoo.diff
+
+ if [ "${ARCH}" = "mips" ]
+ then
+ cd ${S}
+ epatch ${FILESDIR}/openssl-0.9.6-mips.diff
+ fi
+
+ if [ "${ARCH}" = "arm" ]; then
+ # patch linker to add -ldl or things linking aginst libcrypto fail
+ sed -e \
+ 's!^"linux-elf-arm"\(.*\)::BN\(.*\)!"linux-elf-arm"\1:-ldl:BN\2!' \
+ Configure > Configure.orig
+ elif [ "${ARCH}" = "hppa" ]; then
+ sed -e \
+ 's!^"linux-parisc"\(.*\)::BN\(.*\)::!"linux-parisc"\1:-ldl:BN\2::::::::::dlfcn:linux-shared:-fPIC::.so.\\$(SHLIB_MAJOR).\\$(SHLIB_MINOR)!' \
+ Configure > Configure.orig
+ else
+ cp Configure Configure.orig
+ fi
+ sed -e "s/-O3/$CFLAGS/" -e "s/-m486//" Configure.orig > Configure
+}
+
+src_compile() {
+ if [ ${SSH_TARGET} ]; then
+ einfo "Forcing ${SSH_TARGET} compile"
+ ./Configure ${SSH_TARGET} --prefix=/usr \
+ --openssldir=/etc/ssl shared threads || die
+ else
+ ./config --prefix=/usr --openssldir=/etc/ssl shared threads || die
+ fi
+ # i think parallel make has problems
+ make all || die
+
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} MANDIR=/usr/share/man install || die
+ dodoc CHANGES* FAQ LICENSE NEWS README
+ dodoc doc/*.txt
+ dohtml doc/*
+ insinto /usr/share/emacs/site-lisp
+ doins doc/c-indentation.el
+
+ # The man pages rand.3 and passwd.1 conflict with other packages
+ # Rename them to ssl-* and also make a symlink from openssl-* to ssl-*
+ cd ${D}/usr/share/man/man1
+ mv passwd.1 ssl-passwd.1
+ ln -sf ssl-passwd.1 openssl-passwd.1
+ cd ${D}/usr/share/man/man3
+ mv rand.3 ssl-rand.3
+ ln -sf ssl-rand.3 openssl-rand.3
+
+ # create the certs directory. Previous openssl builds
+ # would need to create /usr/lib/ssl/certs but this looks
+ # to be the more FHS compliant setup... -raker
+ dodir /etc/ssl/certs
+
+}
+
+pkg_postinst() {
+ local BN_H="${ROOT}$(gcc-config -L)/include/openssl/bn.h"
+ # Breaks things one some boxen, bug #13795. The problem is that
+ # if we have a 'gcc fixed' version in $(gcc-config -L) from 0.9.6,
+ # then breaks as it was defined as 'int BN_mod(...)' and in 0.9.7 it
+ # is a define with BN_div(...) - <azarah@gentoo.org> (24 Sep 2003)
+ if [ -f "${BN_H}" ] && [ -n "$(grep '^int[[:space:]]*BN_mod(' "${BN_H}")" ]
+ then
+ rm -f "${BN_H}"
+ fi
+}