summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-27 04:29:32 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-27 04:29:32 +0000
commit3b1c0d3f751ddd5b2580bb1906d5e9d369b761c8 (patch)
treecd3c2877574f96b7160594215facc8096bc0489d /dev-libs
parent+dev-libs/DirectFB-extra (diff)
downloadhistorical-3b1c0d3f751ddd5b2580bb1906d5e9d369b761c8.tar.gz
historical-3b1c0d3f751ddd5b2580bb1906d5e9d369b761c8.tar.bz2
historical-3b1c0d3f751ddd5b2580bb1906d5e9d369b761c8.zip
old
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26.2 x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/DirectFB/DirectFB-1.1.1.ebuild144
-rw-r--r--dev-libs/DirectFB/DirectFB-1.2.2.ebuild144
-rw-r--r--dev-libs/DirectFB/DirectFB-1.2.3.ebuild145
-rw-r--r--dev-libs/DirectFB/Manifest13
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.1.1-headers.patch30
5 files changed, 3 insertions, 473 deletions
diff --git a/dev-libs/DirectFB/DirectFB-1.1.1.ebuild b/dev-libs/DirectFB/DirectFB-1.1.1.ebuild
deleted file mode 100644
index c0ecfd5c8c03..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.1.1.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.1.1.ebuild,v 1.4 2008/01/21 06:06:28 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic none nsc nvidia radeon savage sis315 tdfx unichrome"
-IUSE_INPUT_DEVICES="dbox2remote elo-input gunze h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch none permount ps2mouse serialmouse sonypijogdial wm97xx"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="debug fbcon fusion gif jpeg mmx png sdl sse sysfs truetype v4l v4l2 X zlib"
-
-# fusion? ( >=dev-libs/linux-fusion-7.0.1 )
-RDEPEND="sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- sysfs? ( sys-fs/sysfsutils )
- zlib? ( sys-libs/zlib )
- truetype? ( >=media-libs/freetype-2.0.1 )
- X? ( x11-libs/libXext x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto x11-proto/xproto )"
-
-pkg_setup() {
- if [[ -z ${VIDEO_CARDS} ]] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- ewarn "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- echo
- fi
- if [[ -z ${INPUT_DEVICES} ]] ; then
- ewarn "All input drivers will be built since you did not specify"
- ewarn "via the INPUT_DEVICES variable which input drivers to use."
- ewarn "DirectFB supports: ${IUSE_INPUT_DEVICES} all none"
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.9.24-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.1.1-headers.patch
- epatch "${FILESDIR}"/${PN}-1.1.1-pkgconfig.patch
-
- # This is only a partial fix to the X11 order issue #201626. It's just
- # the only part we need in order to make the issue go away. Upstream
- # bug tracker is currently broken, so list things to do here:
- # configure.in:
- # - only add -I/usr/X11R6/include to X11_CFLAGS as needed
- # - only add -L/usr/X11R6/lib to X11_LIBS as needed
- # systems/x11/Makefile.am:
- # - add $(X11_LIBS) to end of _LIBADD variables
- sed -i \
- -e '/X11_LIBS/s:-L/usr/X11R6/lib::' \
- -e '/CFLAGS/s:-I/usr/X11R6/include::' \
- configure
-}
-
-src_compile() {
- local vidcards card input inputdrivers
- if [[ ${VIDEO_CARDS+set} == "set" ]] ; then
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- #use video_cards_${card} && vidcards="${vidcards},${card}"
- done
- [[ -z ${vidcards} ]] \
- && vidcards="none" \
- || vidcards=${vidcards:1}
- else
- vidcards="all"
- fi
- if [[ ${INPUT_DEVICES+set} == "set" ]] ; then
- for input in ${INPUT_DEVICES} ; do
- has ${input} ${IUSE_INPUT_DEVICES} && inputdrivers="${inputdrivers},${input}"
- #use input_devics_${input} && inputdrivers="${inputdrivers},${input}"
- done
- [[ -z ${inputdrivers} ]] \
- && inputdrivers="none" \
- || inputdrivers=${inputdrivers:1}
- else
- inputdrivers="all"
- fi
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- econf \
- --enable-static \
- $(use_enable X x11) \
- $(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable fusion multi) \
- $(use_enable debug) \
- $(use_enable sysfs) \
- $(use_enable zlib) \
- $(use_enable v4l video4linux) \
- $(use_enable v4l2 video4linux2) \
- ${sdlconf} \
- --with-gfxdrivers="${vidcards}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might"
- ewarn "get your mouse unexpectedly set in absolute"
- ewarn "mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from"
- ewarn "INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/DirectFB-1.2.2.ebuild b/dev-libs/DirectFB/DirectFB-1.2.2.ebuild
deleted file mode 100644
index d27d553df17b..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.2.2.ebuild
+++ /dev/null
@@ -1,144 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.2.2.ebuild,v 1.1 2008/08/16 15:15:01 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic none nsc nvidia radeon savage sis315 tdfx unichrome"
-IUSE_INPUT_DEVICES="dbox2remote elo-input gunze h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch none permount ps2mouse serialmouse sonypijogdial wm97xx"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="debug fbcon fusion gif jpeg mmx png sdl sse sysfs truetype v4l v4l2 X zlib"
-
-# fusion? ( >=dev-libs/linux-fusion-8.0.0 )
-RDEPEND="sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- sysfs? ( sys-fs/sysfsutils )
- zlib? ( sys-libs/zlib )
- truetype? ( >=media-libs/freetype-2.0.1 )
- X? ( x11-libs/libXext x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto x11-proto/xproto )"
-
-pkg_setup() {
- if [[ -z ${VIDEO_CARDS} ]] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- ewarn "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- echo
- fi
- if [[ -z ${INPUT_DEVICES} ]] ; then
- ewarn "All input drivers will be built since you did not specify"
- ewarn "via the INPUT_DEVICES variable which input drivers to use."
- ewarn "DirectFB supports: ${IUSE_INPUT_DEVICES} all none"
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.9.24-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.2.0-headers.patch
- epatch "${FILESDIR}"/${PN}-1.1.1-pkgconfig.patch
-
- # This is only a partial fix to the X11 order issue #201626. It's just
- # the only part we need in order to make the issue go away. Upstream
- # bug tracker is currently broken, so list things to do here:
- # configure.in:
- # - only add -I/usr/X11R6/include to X11_CFLAGS as needed
- # - only add -L/usr/X11R6/lib to X11_LIBS as needed
- # systems/x11/Makefile.am:
- # - add $(X11_LIBS) to end of _LIBADD variables
- sed -i \
- -e '/X11_LIBS/s:-L/usr/X11R6/lib::' \
- -e '/CFLAGS/s:-I/usr/X11R6/include::' \
- configure
-}
-
-src_compile() {
- local vidcards card input inputdrivers
- if [[ ${VIDEO_CARDS+set} == "set" ]] ; then
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- #use video_cards_${card} && vidcards="${vidcards},${card}"
- done
- [[ -z ${vidcards} ]] \
- && vidcards="none" \
- || vidcards=${vidcards:1}
- else
- vidcards="all"
- fi
- if [[ ${INPUT_DEVICES+set} == "set" ]] ; then
- for input in ${INPUT_DEVICES} ; do
- has ${input} ${IUSE_INPUT_DEVICES} && inputdrivers="${inputdrivers},${input}"
- #use input_devics_${input} && inputdrivers="${inputdrivers},${input}"
- done
- [[ -z ${inputdrivers} ]] \
- && inputdrivers="none" \
- || inputdrivers=${inputdrivers:1}
- else
- inputdrivers="all"
- fi
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- econf \
- --enable-static \
- $(use_enable X x11) \
- $(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable fusion multi) \
- $(use_enable debug) \
- $(use_enable sysfs) \
- $(use_enable zlib) \
- $(use_enable v4l video4linux) \
- $(use_enable v4l2 video4linux2) \
- ${sdlconf} \
- --with-gfxdrivers="${vidcards}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might"
- ewarn "get your mouse unexpectedly set in absolute"
- ewarn "mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from"
- ewarn "INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/DirectFB-1.2.3.ebuild b/dev-libs/DirectFB/DirectFB-1.2.3.ebuild
deleted file mode 100644
index 2999212577d2..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.2.3.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.2.3.ebuild,v 1.1 2008/08/19 16:53:37 vapier Exp $
-
-inherit eutils toolchain-funcs
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic none nsc nvidia radeon savage sis315 tdfx unichrome"
-IUSE_INPUT_DEVICES="dbox2remote elo-input gunze h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch none permount ps2mouse serialmouse sonypijogdial wm97xx"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://directfb.org/downloads/Core/${P}.tar.gz
- http://directfb.org/downloads/Old/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="debug fbcon fusion gif jpeg mmx png sdl sse sysfs truetype v4l v4l2 X zlib"
-
-# fusion? ( >=dev-libs/linux-fusion-8.0.0 )
-RDEPEND="sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- sysfs? ( sys-fs/sysfsutils )
- zlib? ( sys-libs/zlib )
- truetype? ( >=media-libs/freetype-2.0.1 )
- X? ( x11-libs/libXext x11-libs/libX11 )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto x11-proto/xproto )"
-
-pkg_setup() {
- if [[ -z ${VIDEO_CARDS} ]] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- ewarn "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- echo
- fi
- if [[ -z ${INPUT_DEVICES} ]] ; then
- ewarn "All input drivers will be built since you did not specify"
- ewarn "via the INPUT_DEVICES variable which input drivers to use."
- ewarn "DirectFB supports: ${IUSE_INPUT_DEVICES} all none"
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.9.24-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.2.0-headers.patch
- epatch "${FILESDIR}"/${PN}-1.1.1-pkgconfig.patch
-
- # This is only a partial fix to the X11 order issue #201626. It's just
- # the only part we need in order to make the issue go away. Upstream
- # bug tracker is currently broken, so list things to do here:
- # configure.in:
- # - only add -I/usr/X11R6/include to X11_CFLAGS as needed
- # - only add -L/usr/X11R6/lib to X11_LIBS as needed
- # systems/x11/Makefile.am:
- # - add $(X11_LIBS) to end of _LIBADD variables
- sed -i \
- -e '/X11_LIBS/s:-L/usr/X11R6/lib::' \
- -e '/CFLAGS/s:-I/usr/X11R6/include::' \
- configure
-}
-
-src_compile() {
- local vidcards card input inputdrivers
- if [[ ${VIDEO_CARDS+set} == "set" ]] ; then
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- #use video_cards_${card} && vidcards="${vidcards},${card}"
- done
- [[ -z ${vidcards} ]] \
- && vidcards="none" \
- || vidcards=${vidcards:1}
- else
- vidcards="all"
- fi
- if [[ ${INPUT_DEVICES+set} == "set" ]] ; then
- for input in ${INPUT_DEVICES} ; do
- has ${input} ${IUSE_INPUT_DEVICES} && inputdrivers="${inputdrivers},${input}"
- #use input_devics_${input} && inputdrivers="${inputdrivers},${input}"
- done
- [[ -z ${inputdrivers} ]] \
- && inputdrivers="none" \
- || inputdrivers=${inputdrivers:1}
- else
- inputdrivers="all"
- fi
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- econf \
- --enable-static \
- $(use_enable X x11) \
- $(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable fusion multi) \
- $(use_enable debug) \
- $(use_enable sysfs) \
- $(use_enable zlib) \
- $(use_enable v4l video4linux) \
- $(use_enable v4l2 video4linux2) \
- ${sdlconf} \
- --with-gfxdrivers="${vidcards}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might"
- ewarn "get your mouse unexpectedly set in absolute"
- ewarn "mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from"
- ewarn "INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/Manifest b/dev-libs/DirectFB/Manifest
index a9a971e862ed..20ee104cac94 100644
--- a/dev-libs/DirectFB/Manifest
+++ b/dev-libs/DirectFB/Manifest
@@ -3,25 +3,18 @@ Hash: SHA1
AUX DirectFB-0.9.24-CFLAGS.patch 570 RMD160 e65704cfdedd20ba96544357ab89aeb26927e2af SHA1 bb6c670639fb2292e9ab65abbac5d1e0012847cf SHA256 24fc37fa6390340f08f4cf352a6fec34acf9d2bf0fc0f572a714466cc8ab4b68
AUX DirectFB-0.9.25.1-headers.patch 1739 RMD160 f2e710b7e55e21dbae1267a526d945978afab501 SHA1 3124c358490ea0ef1e227bc172c54df459498ed8 SHA256 83b1eeab6641a51ba49e9c120e5c9c157195f29305f302a8fd9cded9fa350b20
-AUX DirectFB-1.1.1-headers.patch 698 RMD160 abda64eded24e06125d53b07ee6b0ab39583139f SHA1 e5c4c5396e4a1dd97744cf31df3e1ea46633e8ba SHA256 40bcf37f11e79b23325fcea626246cb1d4b86ce31dde439cab322d69b9538fc8
AUX DirectFB-1.1.1-pkgconfig.patch 637 RMD160 b560f0cb45ab3e8938bce474f1331562ba3a96a1 SHA1 aa202a8452f48f1a8ce087201bcc26ef17c97faa SHA256 f824293e1ae8ed2e632ba0196cf760459006a1e110abac348476b3982a0db036
AUX DirectFB-1.2.0-headers.patch 430 RMD160 a783b9d0169241d92504ceb9a41545afa986384a SHA1 78f0b76da583702e730fed19288eb5b94be996f2 SHA256 f1c3c6f420ca7864435d8c69a80c239c4ff9ed6d46ac9ba14b59c6ffa6970b45
DIST DirectFB-0.9.25.1.tar.gz 2064010 RMD160 558e3eabc41635c054314d8a4c8365d648ec588d SHA1 40654da2fde2fd5539f5a0c5cdac50e1a8a52bb4 SHA256 aa1e9710ca18633ffcb74a0383fdfa39aba63e873ec9fa2ba4b7589ed2e5c56b
-DIST DirectFB-1.1.1.tar.gz 2614203 RMD160 08553be77c24f3f9accbe8d2304530b42bbc2e58 SHA1 93d0ea5ca4b10291ca55d1eb6fecc544966eadad SHA256 f12ec5f0864d85268a8d67e4919cb7f3d7f0e06ed6cc278c952f6c342673d931
-DIST DirectFB-1.2.2.tar.gz 2729242 RMD160 07c63cfce2da608cddf96cb75d8e3a821c5b8157 SHA1 02db600a137ec24bacac62acf5dbaa060351718f SHA256 85f483b87e25913745e4b02b0ac13ab44caee743d0a0ff2be91b2dcf3e2af733
-DIST DirectFB-1.2.3.tar.gz 2731205 RMD160 19a3193510eb39e0decf4a2167df0ce0de2ab06c SHA1 0147bde94891811da7e11dc633263bc66b56497e SHA256 0875e553a17fe65e920ad810a67aa6faca582c53476d8dc75880a6b3da625d0b
DIST DirectFB-1.2.6.tar.gz 2794024 RMD160 4a9efea871256bc4c2c08748f5d47f5b9bff3854 SHA1 505ec1cc8e7be62bb0877a7840072224af8925d6 SHA256 0d272ff0d4388e2f2f9c2a2697da8835467ae0cf2c066d83d24f81cd12330f2e
EBUILD DirectFB-0.9.25.1.ebuild 4121 RMD160 b81bea1c36281ec56279db08fe57c9d93de137fd SHA1 dbb0e079f23e693d94e081ad7b21beaaaf4d19eb SHA256 fc42241cdd512c47f496cef63df70c78e40dc09e2562c388eb5afdd7caf83d74
-EBUILD DirectFB-1.1.1.ebuild 4735 RMD160 5a4dcaf3569c038edb9c792be1d5162318801b3b SHA1 d6d9de2f480ede684a796266e9d104eca530f10b SHA256 41ede7d7671c745c22239c8de5c7ec9cca05a25875a1cf4ae326e754aa825d05
-EBUILD DirectFB-1.2.2.ebuild 4735 RMD160 f725c283fbdb2499353cfae51f056833c65d290f SHA1 99a88e04208845741318f6e8d59a9a4ede1e6dc1 SHA256 50c77675358fc861f15c5464e23e4dbfb0da7ec812d5b8e3c3cef4e2a3e23845
-EBUILD DirectFB-1.2.3.ebuild 4775 RMD160 e29172643636f5a840de0f9ae302acfef907c49f SHA1 d20758d6b3270a1d4408e4cb40b9ff182bb2d8fc SHA256 fd0b66938791e5998e76963517cbffa8d464a9f654891d90e84e718913fc51db
EBUILD DirectFB-1.2.6.ebuild 4775 RMD160 5cf7c54fc632b9534b8449d707cd3b2e1a5e140c SHA1 88245c8303d3106a61e85d9e1deeaa3418d61ed5 SHA256 9d38d83d7c869ad77387800d7af0bc6021fdc6d323b388ee8dbb01959b4d2f4e
MISC ChangeLog 11100 RMD160 7e5ff5cda9237f609de75aec23955ace62b2fb48 SHA1 57cfacd89b19ca0957ae31c57cfa679ba564530c SHA256 5060ec873eab92b3c4d4af204cc6f66415b998f4f77818a311d65880d8d987be
MISC metadata.xml 946 RMD160 777ebf08757a4edd565f7bd223842eea95bfb8ed SHA1 bce4580dc619e70662cf503cf71d91ad26b9ae64 SHA256 4851e050a8193f7bf60c757d1b7307709ef0ad6b40a5feae964cca0caf445232
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
-iEYEARECAAYFAkjuW/IACgkQ67wieSYcaxd9ygCg7GlvZWbcb3+pM/C6H0DpOgwQ
-R14AoNj6M2/9hBiIMtcz5d3XbbNAjfYB
-=1FJI
+iEYEARECAAYFAkkFQ7EACgkQ67wieSYcaxe1iQCaA9bOrYCeQCUFPqFAMHsusMkg
+Ol4An0qUGGniBXKBUt0aa3wSTjbw7Pto
+=1HSt
-----END PGP SIGNATURE-----
diff --git a/dev-libs/DirectFB/files/DirectFB-1.1.1-headers.patch b/dev-libs/DirectFB/files/DirectFB-1.1.1-headers.patch
deleted file mode 100644
index df9ef99353d3..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.1.1-headers.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Don't rely on the kernel to tell us what the cpu target is ... we'll just
-use the default values all the time instead.
-
-http://bugs.gentoo.org/152614
-
---- lib/direct/ppcasm_memcpy_cachable.S
-+++ lib/direct/ppcasm_memcpy_cachable.S
-@@ -34,8 +34,6 @@
-
- #define __ASSEMBLY__
-
--#include <linux/config.h>
--
- #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
- #define L1_CACHE_LINE_SIZE 16
- #define LG_L1_CACHE_LINE_SIZE 4
-
-Don't pollute the namespace with define hacks, just use the real deal.
-
---- include/dfb_types.h
-+++ include/dfb_types.h
-@@ -60,6 +60,8 @@
-
- #endif
-
-+#include <asm/types.h>
-+#define DIRECTFB_NO_CRUFT
- #ifndef DIRECTFB_NO_CRUFT
- #define __u8 u8
- #define __u16 u16