summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-22 17:58:14 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-22 17:58:14 +0000
commit4e43e85890541a3c6b4c8f2d8865ad1a7bc423e9 (patch)
treed17c448f3c603927385c38253f8590fafb96f979 /dev-libs
parentunmask arphicfonts (diff)
downloadhistorical-4e43e85890541a3c6b4c8f2d8865ad1a7bc423e9.tar.gz
historical-4e43e85890541a3c6b4c8f2d8865ad1a7bc423e9.tar.bz2
historical-4e43e85890541a3c6b4c8f2d8865ad1a7bc423e9.zip
Enabled finer grained auth mechanism controls as suggested by Eric
Renfro. There are use variables for all relevant configure switches now. By default pam authentication is enabled and any of the other insecure, unsupported, or non-standard mechanisms are disabled.
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog11
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r1.ebuild114
-rw-r--r--dev-libs/cyrus-sasl/files/crypt.diff12
3 files changed, 136 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 31397fc9f216..006fabd2575c 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.13 2002/08/16 05:03:44 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.14 2002/08/22 17:58:14 raker Exp $
+
+*cyrus-sasl-2.1.7-r1 (22 Aug 2002)
+
+ 22 Aug 2002; Nick Hadaway <raker@gentoo.org> cyrus-sasl-2.1.7-r1.ebuild,
+ files/digest-cyrus-sasl-2.1.7-r1.ebuild, files/crypt.diff :
+ Enabled finer grained auth mechanism controls as suggested by Eric Renfro.
+ There are use variables for all relevant configure switches now. By
+ default pam authentication is enabled and any of the other insecure,
+ unsupported, or non-standard mechanisms are disabled.
*cyrus-sasl-2.1.7 (13 Aug 2002)
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r1.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r1.ebuild
new file mode 100644
index 000000000000..ddd61f1672fb
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.7-r1.ebuild,v 1.1 2002/08/22 17:58:14 raker Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/sasl/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+DEPEND="virtual/glibc
+ >=sys-libs/db-3.2
+ >=sys-libs/pam-0.75
+ >=dev-libs/openssl-0.9.6d
+ cyrus-gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ cyrus-berkdb? ( >=sys-libs/db-3.2.9 )
+ cyrus-ldap? ( >=net-nds/openldap-2.0.25 )
+ cyrus-mysql? ( >=dev-db/mysql-3.23.51 )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/cyrus-sasl-iovec.diff || die
+ patch -p1 < ${FILESDIR}/crypt.diff || die
+
+}
+
+src_compile() {
+
+ local myconf
+
+ use sasl-ldap && myconf="${myconf} --with-ldap" \
+ || myconf="${myconf} --without-ldap"
+
+ use sasl-mysql && myconf="${myconf} --with-mysql" \
+ || myconf="${myconf} --without-mysql"
+
+ if use cyrus-berkdb; then
+ myconf="${myconf} --with-dblib=berkeley"
+ elif use cyrus-gdbm; then
+ myconf="${myconf} --with-dblib=gdbm --with-gdbm=/usr"
+ else
+ myconf="${myconf} --with-dblib=berkeley"
+ fi
+
+ use sasl-anon && myconf="${myconf} --enable-anon" \
+ || myconf="${myconf} --disable-anon"
+
+ use sasl-login && myconf="${myconf} --enable-login" \
+ || myconf="${myconf} --disable-login"
+
+ use sasl-scram && myconf="${myconf} --enable-scram" \
+ || myconf="${myconf} --disable-scram"
+
+ use sasl-plain && myconf="${myconf} --enable-plain" \
+ || myconf="${myconf} --disable-plain"
+
+ use sasl-krb4 && myconf="${myconf} --enable-krb4" \
+ || myconf="${myconf} --disable-krb4"
+
+ use sasl-gssapi && myconf="${myconf} --enable-gssapi" \
+ || myconf="${myconf} --disable-gssapi"
+
+ use sasl-opie && myconf="${myconf} --enable-opie" \
+ || myconf="${myconf} --disable-opie"
+
+ use static && myconf="${myconf} --enable-static --with-staticsasl" \
+ || myconf="${myconf} --disable-static --without-staticsasl"
+
+ econf \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-openssl=/usr \
+ --with-plugindir=/usr/lib/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ --with-des \
+ --with-rc4 \
+ --enable-pam \
+ --enable-login \
+ --with-gnu-ld \
+ --enable-shared \
+ --disable-sample \
+ --enable-cram \
+ --enable-digest \
+ ${myconf} || die "bad ./configure"
+
+ make || die "compile problem"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "install problem"
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README doc/*.txt
+ docinto examples ; dodoc sample/{*.[ch],Makefile}
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*
+
+ insinto /etc/conf.d ; newins ${FILESDIR}/saslauthd.confd saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/saslauthd2.rc6 saslauthd
+ exeinto /etc/init.d ; newexe ${FILESDIR}/pwcheck.rc6 pwcheck
+}
+
+pkg_postinst() {
+ # empty directories..
+ install -d -m0755 ${ROOT}/var/lib/sasl2
+ install -d -m0755 ${ROOT}/etc/sasl2
+}
diff --git a/dev-libs/cyrus-sasl/files/crypt.diff b/dev-libs/cyrus-sasl/files/crypt.diff
new file mode 100644
index 000000000000..68cfaf9536c3
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/crypt.diff
@@ -0,0 +1,12 @@
+diff -urN cyrus-sasl-2.1.7/saslauthd/Makefile.in cyrus-sasl-2.1.7-modified/saslauthd/Makefile.in
+--- cyrus-sasl-2.1.7/saslauthd/Makefile.in Fri Aug 9 11:13:07 2002
++++ cyrus-sasl-2.1.7-modified/saslauthd/Makefile.in Thu Aug 22 12:48:28 2002
+@@ -234,7 +234,7 @@
+
+ saslauthd: $(saslauthd_OBJECTS) $(saslauthd_DEPENDENCIES)
+ @rm -f saslauthd
+- $(LINK) $(saslauthd_LDFLAGS) $(saslauthd_OBJECTS) $(saslauthd_LDADD) $(LIBS)
++ $(LINK) $(saslauthd_LDFLAGS) $(saslauthd_OBJECTS) $(saslauthd_LDADD) $(LIBS) $(LIB_CRYPT)
+
+ tags: TAGS
+