summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-10-26 00:31:06 +0000
committerDaniel Goller <morfic@gentoo.org>2005-10-26 00:31:06 +0000
commita30a8b798bfe9b8c45888fda923793b52ae21b4b (patch)
tree7973eb35ff540e523c13c4de18cd800017cd6c4f /dev-libs
parentinitial version of quake3-from-source #103591 (diff)
downloadhistorical-a30a8b798bfe9b8c45888fda923793b52ae21b4b.tar.gz
historical-a30a8b798bfe9b8c45888fda923793b52ae21b4b.tar.bz2
historical-a30a8b798bfe9b8c45888fda923793b52ae21b4b.zip
Don't check icc path unless we have USE=icc
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/Manifest12
-rw-r--r--dev-libs/boost/boost-1.33.0-r1.ebuild23
2 files changed, 22 insertions, 13 deletions
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index 1b7928071900..bb45ee99a458 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 26334aff7fedef42798e3a5bb8e45063 ChangeLog 9060
MD5 d259ae434e176df207cba3deab973f61 boost-1.29.0.ebuild 1426
MD5 34d13e0eeb58e13e1992908d04d51b45 boost-1.30.0.ebuild 2973
@@ -8,7 +11,7 @@ MD5 37f8eb8b22a26f2bc30b6101d14cb9d0 boost-1.32.0-r2.ebuild 5690
MD5 76f87ddbbddd80f054d8d005d4d66d92 boost-1.32.0-r3.ebuild 6183
MD5 8d4eca3eb59bc23e2d53b3d0cfd06c97 boost-1.32.0.ebuild 2294
MD5 16a0704d7282649d4c5920e3c8b39bee metadata.xml 343
-MD5 daa33f312b8c1de18d68bb08d6074d0d boost-1.33.0-r1.ebuild 7129
+MD5 e755f7466c30323264e35d4c8db4704b boost-1.33.0-r1.ebuild 7159
MD5 421fe3be35fd6d405bf2b3381d51867f boost-1.33.0.ebuild 6259
MD5 9f4b3bf1104d681375b01af831179ee8 boost-1.32.0-r4.ebuild 6263
MD5 ed187a2b2048776a7e5b27060d96938c files/digest-boost-1.29.0 65
@@ -23,3 +26,10 @@ MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r4 67
MD5 612f486fa190f86f9be3a17465036dd0 files/digest-boost-1.33.0 67
MD5 238bb8043f0cdc8bd91f81bd0b55f92a files/boost-alpha-threads.patch 1111
MD5 612f486fa190f86f9be3a17465036dd0 files/digest-boost-1.33.0-r1 67
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDXs5Z/aM9DdBw91cRAnCqAKDCxm7bhI98agtp7BEccN16VPtJ6gCeO8ow
+rwNcpg6kfaFUBjHPtvUe0zc=
+=G9F3
+-----END PGP SIGNATURE-----
diff --git a/dev-libs/boost/boost-1.33.0-r1.ebuild b/dev-libs/boost/boost-1.33.0-r1.ebuild
index 97ffcf8236cd..77510c63df34 100644
--- a/dev-libs/boost/boost-1.33.0-r1.ebuild
+++ b/dev-libs/boost/boost-1.33.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.0-r1.ebuild,v 1.2 2005/10/25 20:10:35 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.0-r1.ebuild,v 1.3 2005/10/26 00:31:06 morfic Exp $
# This ebuild was generated by Ebuilder v0.4.
inherit python distutils multilib eutils
@@ -45,19 +45,20 @@ pkg_setup() {
SOSUFFIX="so"
fi
#Check ICC path and use this instead of hardcoding it, thanks to Peter Koeleman
- if [ "X${IA32ROOT}" == "X" ]; then
- # try IA64ROOT
- if [ "X${IA64ROOT}" == "X" ]; then
- # this shouldn't happen when icc is properly installed
- eerror "Could not find path to Intel compiler"
+ if use icc; then
+ if [ "X${IA32ROOT}" == "X" ]; then
+ # try IA64ROOT
+ if [ "X${IA64ROOT}" == "X" ]; then
+ # this shouldn't happen when icc is properly installed
+ eerror "Could not find path to Intel compiler"
+ else
+ INTEL_PATH="${IA64ROOT}"
+ fi
else
- INTEL_PATH="${IA64ROOT}"
+ INTEL_PATH="${IA32ROOT}"
fi
- else
- INTEL_PATH="${IA32ROOT}"
fi
-
if use static ; then
BUILD="release <runtime-link>static"
else
@@ -126,7 +127,6 @@ src_compile() {
-sBUILD="${BUILD}" \
--prefix=${D}/usr \
--layout=system
-
else
${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
-sPYTHON_ROOT=/usr \
@@ -143,7 +143,6 @@ src_compile() {
-sBUILD="${BUILD}" \
--prefix=${D}/usr \
--layout=system
-
fi
if use pyste; then