summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-23 19:13:52 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-23 19:13:52 +0000
commitbd35a571c5522739e693b95226452dd051835a03 (patch)
tree182abe683a6de76646ee63c2043393de7247cb75 /dev-libs
parentDelete older ebuild. (diff)
downloadhistorical-bd35a571c5522739e693b95226452dd051835a03.tar.gz
historical-bd35a571c5522739e693b95226452dd051835a03.tar.bz2
historical-bd35a571c5522739e693b95226452dd051835a03.zip
Version bump.
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/xapian-bindings/ChangeLog8
-rw-r--r--dev-libs/xapian-bindings/xapian-bindings-1.0.19.ebuild115
-rw-r--r--dev-libs/xapian/ChangeLog8
-rw-r--r--dev-libs/xapian/xapian-1.0.19.ebuild29
4 files changed, 158 insertions, 2 deletions
diff --git a/dev-libs/xapian-bindings/ChangeLog b/dev-libs/xapian-bindings/ChangeLog
index 829b88d88a5f..162e6e319e46 100644
--- a/dev-libs/xapian-bindings/ChangeLog
+++ b/dev-libs/xapian-bindings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/xapian-bindings
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.13 2010/03/10 09:34:25 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/ChangeLog,v 1.14 2010/04/23 19:13:52 arfrever Exp $
+
+*xapian-bindings-1.0.19 (23 Apr 2010)
+
+ 23 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -xapian-bindings-1.0.16.ebuild, +xapian-bindings-1.0.19.ebuild:
+ Version bump.
10 Mar 2010; Joseph Jezak <josejx@gentoo.org>
xapian-bindings-1.0.17.ebuild:
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.0.19.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.0.19.ebuild
new file mode 100644
index 000000000000..02259ecede87
--- /dev/null
+++ b/dev-libs/xapian-bindings/xapian-bindings-1.0.19.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian-bindings/xapian-bindings-1.0.19.ebuild,v 1.1 2010/04/23 19:13:52 arfrever Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit java-pkg-opt-2 mono python
+
+DESCRIPTION="SWIG and JNI bindings for Xapian"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="java mono php python ruby tcl"
+
+COMMONDEPEND="=dev-libs/xapian-${PV}
+ mono? ( >=dev-lang/mono-1.0.8 )
+ php? ( >=dev-lang/php-4 )
+ python? ( =dev-lang/python-2*[threads] )
+ ruby? ( dev-lang/ruby )
+ tcl? ( >=dev-lang/tcl-8.1 )"
+DEPEND="${COMMONDEPEND}
+ python? ( >=dev-lang/swig-1.3.29-r1 )
+ java? ( >=virtual/jdk-1.3 )"
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.3 )"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_prepare() {
+ sed \
+ -e 's:\(^pylib_DATA = xapian.py\).*:\1:' \
+ -e 's|\(^xapian.py: modern/xapian.py\)|\1 _xapian$(PYTHON_SO)|' \
+ -i python/Makefile.{am,in} || die "sed failed"
+}
+
+src_configure() {
+ if use java; then
+ CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
+ fi
+ econf \
+ $(use_with java) \
+ $(use_with mono csharp) \
+ $(use_with php) \
+ $(use_with python) \
+ $(use_with ruby) \
+ $(use_with tcl)
+
+ # Python bindings are built/tested/installed manually.
+ sed -e "/SUBDIRS =/s/ python//" -i Makefile || die "sed Makefile"
+}
+
+src_compile() {
+ default
+
+ if use python; then
+ python_copy_sources python
+ building() {
+ emake PYTHON="$(PYTHON)" PYTHON_INC="$(python_get_includedir)" PYTHON_LIB="$(python_get_libdir)" pylibdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir python building
+ fi
+}
+
+src_test() {
+ default
+
+ if use python; then
+ testing() {
+ emake PYTHON="$(PYTHON)" PYTHON_INC="$(python_get_includedir)" PYTHON_LIB="$(python_get_libdir)" pylibdir="$(python_get_sitedir)" check
+ }
+ python_execute_function -s --source-dir python testing
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use java; then
+ java-pkg_dojar java/built/xapian_jni.jar
+ # TODO: make the build system not install this...
+ java-pkg_doso "${D}/${S}/java/built/libxapian_jni.so"
+ rm "${D}/${S}/java/built/libxapian_jni.so"
+ rmdir -p "${D}/${S}/java/built"
+ rmdir -p "${D}/${S}/java/native"
+ fi
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYTHON="$(PYTHON)" PYTHON_INC="$(python_get_includedir)" PYTHON_LIB="$(python_get_libdir)" pylibdir="$(python_get_sitedir)" install
+ }
+ python_execute_function -s --source-dir python installation
+ fi
+
+ # For some USE combos this directory is not created
+ if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
+ mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}"
+ fi
+
+ dodoc AUTHORS HACKING NEWS TODO README || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize xapian.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup xapian.py
+ fi
+}
diff --git a/dev-libs/xapian/ChangeLog b/dev-libs/xapian/ChangeLog
index d96892253b81..1d08ea693308 100644
--- a/dev-libs/xapian/ChangeLog
+++ b/dev-libs/xapian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/xapian
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.39 2010/01/06 22:31:57 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/ChangeLog,v 1.40 2010/04/23 19:11:44 arfrever Exp $
+
+*xapian-1.0.19 (23 Apr 2010)
+
+ 23 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -xapian-1.0.16.ebuild, +xapian-1.0.19.ebuild:
+ Version bump.
06 Jan 2010; Markus Meier <maekke@gentoo.org> xapian-1.0.17.ebuild:
x86 stable, bug #297935
diff --git a/dev-libs/xapian/xapian-1.0.19.ebuild b/dev-libs/xapian/xapian-1.0.19.ebuild
new file mode 100644
index 000000000000..08512758791f
--- /dev/null
+++ b/dev-libs/xapian/xapian-1.0.19.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/xapian/xapian-1.0.19.ebuild,v 1.1 2010/04/23 19:11:44 arfrever Exp $
+
+EAPI="3"
+
+MY_P="${PN}-core-${PV}"
+
+DESCRIPTION="Xapian Probabilistic Information Retrieval library"
+HOMEPAGE="http://www.xapian.org/"
+SRC_URI="http://oligarchy.co.uk/xapian/${PV}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ mv "${D}usr/share/doc/xapian-core" "${D}usr/share/doc/${PF}"
+
+ dodoc AUTHORS HACKING PLATFORMS README NEWS || die "dodoc failed"
+}