summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-11-21 04:23:25 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-11-21 04:23:25 +0000
commit7522996ff4bc64230e12f63fe6d56b7ba3bd85f2 (patch)
treeca1b815ff760d1c4bf61ea36354f53c08a51acd4 /dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.10.ebuild
parentStable for HPPA, despite the 4 failed tests. (diff)
downloadhistorical-7522996ff4bc64230e12f63fe6d56b7ba3bd85f2.tar.gz
historical-7522996ff4bc64230e12f63fe6d56b7ba3bd85f2.tar.bz2
historical-7522996ff4bc64230e12f63fe6d56b7ba3bd85f2.zip
Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
Package-Manager: portage-2.1.2_rc2
Diffstat (limited to 'dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.10.ebuild')
-rw-r--r--dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.10.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.10.ebuild b/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.10.ebuild
new file mode 100644
index 000000000000..bccdb8ccdd97
--- /dev/null
+++ b/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-hunchentoot/cl-hunchentoot-0.4.10.ebuild,v 1.1 2006/11/21 04:23:25 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Hunchentoot is a web server written in Common Lisp and at the same time a toolkit for building dynamic websites with Common Lisp."
+HOMEPAGE="http://weitz.de/hunchentoot/"
+SRC_URI="mirror://gentoo/hunchentoot_${PV}.orig.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-rfc2388
+ dev-lisp/cl-plus-ssl
+ dev-lisp/cl-chunga
+ dev-lisp/cl-ppcre
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-who"
+SLOT="0"
+
+CLPACKAGE="hunchentoot hunchentoot-test"
+
+S=${WORKDIR}/hunchentoot-${PV}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ insinto $CLSOURCEROOT/hunchentoot/test
+ doins test/*
+ for i in hunchentoot{,-test}; do
+ dosym $CLSOURCEROOT/hunchentoot/$i.asd $CLSYSTEMROOT/$i.asd
+ done
+ dodoc CHANGELOG* README
+ dohtml -r doc/*
+}