summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-09-25 20:15:43 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-09-25 20:15:43 +0000
commit399c8aa48d0d8c38fcb3653f1194663dfda14d9a (patch)
treed9509d030160cb6f1821245b679b06289efec7b7 /dev-ml/camlidl/camlidl-1.05.ebuild
parentStable on sparc. (diff)
downloadhistorical-399c8aa48d0d8c38fcb3653f1194663dfda14d9a.tar.gz
historical-399c8aa48d0d8c38fcb3653f1194663dfda14d9a.tar.bz2
historical-399c8aa48d0d8c38fcb3653f1194663dfda14d9a.zip
New package for generating bindings to C/C++ libs, fixes bug #65138.
Diffstat (limited to 'dev-ml/camlidl/camlidl-1.05.ebuild')
-rw-r--r--dev-ml/camlidl/camlidl-1.05.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/camlidl/camlidl-1.05.ebuild b/dev-ml/camlidl/camlidl-1.05.ebuild
new file mode 100644
index 000000000000..e51f30a73c2c
--- /dev/null
+++ b/dev-ml/camlidl/camlidl-1.05.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlidl/camlidl-1.05.ebuild,v 1.1 2004/09/25 20:15:43 mattam Exp $
+
+DESCRIPTION="CamlIDL is a stub code generator for using C/C++ libraries from O'Caml"
+HOMEPAGE="http://caml.inria.fr/camlidl/"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE=""
+DEPEND=">=dev-lang/ocaml-3.07"
+
+src_compile() {
+ # Use the UNIX makefile
+ libdir=`ocamlc -where`
+ sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix
+ sed -i -e "s|BINDIR=.*|BINDIR=/usr/bin|" config/Makefile.unix
+ ln -s Makefile.unix config/Makefile
+
+ # Make
+ emake -j1 || die
+}
+
+src_test() {
+ einfo "Running tests..."
+ cd tests
+ ( make CCPP=g++ && einfo "Tests finished successfully" ) || die "Tests failed"
+}
+
+src_install() {
+ libdir=`ocamlc -where`
+ dodir ${libdir}/caml
+ dodir /usr/bin
+ # Install
+ emake BINDIR=${D}/usr/bin OCAMLLIB=${D}${libdir} install || die
+
+ # Documentation
+ dodoc README Changes
+}