summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:54:47 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:54:47 +0000
commitf64df7559351f5ed153c74f4b53274e97659bb69 (patch)
tree93e4faf76267607b95f9f5cd7d3f9f11fcf86696 /dev-ml/cryptokit/cryptokit-1.3.ebuild
parentShorten DESCRIPTION to under 100 characters in order to make repoman happy. (diff)
downloadhistorical-f64df7559351f5ed153c74f4b53274e97659bb69.tar.gz
historical-f64df7559351f5ed153c74f4b53274e97659bb69.tar.bz2
historical-f64df7559351f5ed153c74f4b53274e97659bb69.zip
Migrate to EAPI 2 in order to nuke built_with_use.
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'dev-ml/cryptokit/cryptokit-1.3.ebuild')
-rw-r--r--dev-ml/cryptokit/cryptokit-1.3.ebuild25
1 files changed, 7 insertions, 18 deletions
diff --git a/dev-ml/cryptokit/cryptokit-1.3.ebuild b/dev-ml/cryptokit/cryptokit-1.3.ebuild
index 12f9cd477f5c..d72dc6d321a1 100644
--- a/dev-ml/cryptokit/cryptokit-1.3.ebuild
+++ b/dev-ml/cryptokit/cryptokit-1.3.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/cryptokit-1.3.ebuild,v 1.4 2008/09/25 12:22:51 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cryptokit/cryptokit-1.3.ebuild,v 1.5 2009/09/28 16:47:43 betelgeuse Exp $
-inherit eutils findlib
+EAPI="2"
-EAPI="1"
+inherit eutils findlib
DESCRIPTION="Cryptographic primitives library for Objective Caml"
HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html"
@@ -14,21 +14,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~x86-fbsd"
IUSE="doc +ocamlopt"
-DEPEND=">=dev-lang/ocaml-3.09
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
>=sys-libs/zlib-1.1"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -e "s/VERSION/${PV}/" "${FILESDIR}/META" >> META
epatch "${FILESDIR}/${PN}-gentoo.patch"
}
@@ -42,7 +31,7 @@ src_compile() {
src_install() {
findlib_src_install
- dodoc Changes README
+ dodoc Changes README || die
use doc && dohtml doc/*.html doc/*.css
}