summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:33:56 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-09-28 16:33:56 +0000
commit7626f8a4429badb1a85ff05ed3662af3002ba63c (patch)
tree755e11ffac3293b48744c48dad76cc02eb133b66 /dev-ml/facile
parentMigrate to EAPI 2 in order to nuke built_with_use. (diff)
downloadhistorical-7626f8a4429badb1a85ff05ed3662af3002ba63c.tar.gz
historical-7626f8a4429badb1a85ff05ed3662af3002ba63c.tar.bz2
historical-7626f8a4429badb1a85ff05ed3662af3002ba63c.zip
Migrate to EAPI 2 in order to nuke built_with_use.
Package-Manager: portage-2.2_rc40/cvs/Linux i686
Diffstat (limited to 'dev-ml/facile')
-rw-r--r--dev-ml/facile/ChangeLog5
-rw-r--r--dev-ml/facile/facile-1.1.ebuild25
2 files changed, 10 insertions, 20 deletions
diff --git a/dev-ml/facile/ChangeLog b/dev-ml/facile/ChangeLog
index 07f652b62380..fa7a8dffdb26 100644
--- a/dev-ml/facile/ChangeLog
+++ b/dev-ml/facile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/facile
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/ChangeLog,v 1.15 2009/01/21 23:27:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/ChangeLog,v 1.16 2009/09/28 16:31:52 betelgeuse Exp $
+
+ 28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org> facile-1.1.ebuild:
+ Migrate to EAPI 2 in order to nuke built_with_use.
21 Jan 2009; Alexis Ballier <aballier@gentoo.org> facile-1.1.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ml/facile/facile-1.1.ebuild b/dev-ml/facile/facile-1.1.ebuild
index 84da343a60d1..53121d5b6a87 100644
--- a/dev-ml/facile/facile-1.1.ebuild
+++ b/dev-ml/facile/facile-1.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.15 2009/01/21 23:27:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/facile/facile-1.1.ebuild,v 1.16 2009/09/28 16:31:52 betelgeuse Exp $
-inherit eutils
+EAPI="2"
-EAPI="1"
+inherit eutils
DESCRIPTION="FaCiLe is a constraint programming library on integer and integer set finite domains written in OCaml."
HOMEPAGE="http://www.recherche.enac.fr/log/facile/"
@@ -17,23 +17,11 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="+ocamlopt"
-RDEPEND=">=dev-lang/ocaml-3.09.3-r1"
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
DEPEND="${RDEPEND}
sys-apps/sed"
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Fix building on FreeBSD
epatch "${FILESDIR}/${P}"-make.patch
# Disable building native code objects if we dont have/want ocamlopt
@@ -48,10 +36,9 @@ src_unpack() {
fi
}
-src_compile(){
+src_configure(){
# This is a custom configure script and it does not support standard options
./configure --faciledir "${D}"$(ocamlc -where)/facile/
- emake || die "Compilation failed"
}
src_test() {