summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-13 20:47:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-13 20:47:36 +0000
commitf1542bce9bcdb1d087e85589afc6f44a6867869f (patch)
treedf6ccd5e3954a28dd13d07eeca4a4d9d0aa56194 /dev-ml/lwt/lwt-2.4.3.ebuild
parentMarked stable for amd64 wrt bug #450904 (diff)
downloadhistorical-f1542bce9bcdb1d087e85589afc6f44a6867869f.tar.gz
historical-f1542bce9bcdb1d087e85589afc6f44a6867869f.tar.bz2
historical-f1542bce9bcdb1d087e85589afc6f44a6867869f.zip
version bump
Package-Manager: portage-2.2.0_alpha151/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'dev-ml/lwt/lwt-2.4.3.ebuild')
-rw-r--r--dev-ml/lwt/lwt-2.4.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/lwt/lwt-2.4.3.ebuild b/dev-ml/lwt/lwt-2.4.3.ebuild
new file mode 100644
index 000000000000..9a3a9c4c786a
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/lwt-2.4.3.ebuild,v 1.1 2013/01/13 20:47:29 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="http://ocsigen.org/download/${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +react +ssl"
+
+DEPEND="react? ( dev-ml/react )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0 )
+ gtk? ( dev-ml/lablgtk dev-libs/glib:2 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+DOCS=( "CHANGES" "CHANGES.darcs" "README" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)" \
+ oasis_src_configure
+}