summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-02-24 15:49:38 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-02-24 15:49:38 +0000
commit018347e3e252b2fa019d91546f5a03809574fbd7 (patch)
treed26175b97658306c601df0247811d64ea26ac67b /dev-ml/ocaml-augeas
parentInitial import, bug #229361. (diff)
downloadhistorical-018347e3e252b2fa019d91546f5a03809574fbd7.tar.gz
historical-018347e3e252b2fa019d91546f5a03809574fbd7.tar.bz2
historical-018347e3e252b2fa019d91546f5a03809574fbd7.zip
Initial import, bug #229361.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/ocaml-augeas')
-rw-r--r--dev-ml/ocaml-augeas/ChangeLog10
-rw-r--r--dev-ml/ocaml-augeas/Manifest4
-rw-r--r--dev-ml/ocaml-augeas/metadata.xml12
-rw-r--r--dev-ml/ocaml-augeas/ocaml-augeas-0.4.ebuild27
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/ocaml-augeas/ChangeLog b/dev-ml/ocaml-augeas/ChangeLog
new file mode 100644
index 000000000000..65508fed4275
--- /dev/null
+++ b/dev-ml/ocaml-augeas/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/ocaml-augeas
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-augeas/ChangeLog,v 1.1 2009/02/24 15:49:38 matsuu Exp $
+
+*ocaml-augeas-0.4 (24 Feb 2009)
+
+ 24 Feb 2009; MATSUU Takuto <matsuu@gentoo.org> +metadata.xml,
+ +ocaml-augeas-0.4.ebuild:
+ Initial import, bug #229361.
+
diff --git a/dev-ml/ocaml-augeas/Manifest b/dev-ml/ocaml-augeas/Manifest
new file mode 100644
index 000000000000..e14cd3131890
--- /dev/null
+++ b/dev-ml/ocaml-augeas/Manifest
@@ -0,0 +1,4 @@
+DIST ocaml-augeas-0.4.tar.gz 55812 RMD160 4fd70fdbc92bbcb2844faa03f93d4ec538f6579c SHA1 a0caa99efb5a1f482df3ed4f9d07685d05d29eb9 SHA256 73b3fe7f2f67ca81ad5ab2c07d50d21a840f2c7579aeaf7027933ba2278cd9e0
+EBUILD ocaml-augeas-0.4.ebuild 590 RMD160 11fe5a5271bb3c1962f4eef6992f68f637ddad3e SHA1 c8af162644f601ce0a25cc1416c897de30a6778d SHA256 9e6f9cbb0d02b426fc516ae2fbeb434bfaf3b1692e0fb4ddaf7f031f61000339
+MISC ChangeLog 368 RMD160 514e251c7f10bdf373d8c368ebff13712c55b707 SHA1 b67eca5501351b566d09672ddd6bdd2492b403d2 SHA256 4c938cff42d503e29dd9132985982dd14342d05289f7b16221e26382d1970af0
+MISC metadata.xml 323 RMD160 1ebeac0b758fdacf1fa4fadacfd4e07d756ac0f1 SHA1 cc608550cd7f8654e79154f7cd076730b48db50b SHA256 abb3864c30413c7d6d8160b2da329f9748c585ed240d8c936d80f7992b08a3dd
diff --git a/dev-ml/ocaml-augeas/metadata.xml b/dev-ml/ocaml-augeas/metadata.xml
new file mode 100644
index 000000000000..b1fac4d18371
--- /dev/null
+++ b/dev-ml/ocaml-augeas/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>matsuu@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+ocaml-augeas is a set of Ocaml bindings around augeas.
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-ml/ocaml-augeas/ocaml-augeas-0.4.ebuild b/dev-ml/ocaml-augeas/ocaml-augeas-0.4.ebuild
new file mode 100644
index 000000000000..a08e975f5561
--- /dev/null
+++ b/dev-ml/ocaml-augeas/ocaml-augeas-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-augeas/ocaml-augeas-0.4.ebuild,v 1.1 2009/02/24 15:49:38 matsuu Exp $
+
+inherit findlib
+
+DESCRIPTION="Ocaml bindings for Augeas"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://augeas.net/download/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-admin/augeas"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf || die
+ # parallel make b0rked
+ emake -j1 || die
+}
+
+src_install() {
+ findlib_src_install
+}