summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-12 07:02:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-12 07:02:41 +0000
commit9247f19c90f6ba04719cb4c82f91dceafb05b3ea (patch)
tree261255ef6645d45da9a039863ac30c4e960f2e50 /dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild
parentremove old (diff)
downloadhistorical-9247f19c90f6ba04719cb4c82f91dceafb05b3ea.tar.gz
historical-9247f19c90f6ba04719cb4c82f91dceafb05b3ea.tar.bz2
historical-9247f19c90f6ba04719cb4c82f91dceafb05b3ea.zip
version bump
Package-Manager: portage-2.1.5_rc10
Diffstat (limited to 'dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild')
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild
new file mode 100644
index 000000000000..c9a8add7c699
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild,v 1.1 2008/05/12 06:57:12 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.09
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+}
+
+src_compile() {
+ econf
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES README TODO
+ use doc && dohtml doc/*
+}