summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-28 19:02:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-28 19:02:05 +0000
commit6f3fa0aca6402bec4ced014ca8e3c2e4a5156e2a (patch)
tree24a01c4d53e5175cfde9715376fc5380e6045756 /dev-ml/ocaml-sqlite3
parentremove old (diff)
downloadhistorical-6f3fa0aca6402bec4ced014ca8e3c2e4a5156e2a.tar.gz
historical-6f3fa0aca6402bec4ced014ca8e3c2e4a5156e2a.tar.bz2
historical-6f3fa0aca6402bec4ced014ca8e3c2e4a5156e2a.zip
remove old
Package-Manager: portage-2.2_rc42/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/ocaml-sqlite3')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog7
-rw-r--r--dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.2.0-werror.patch13
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild58
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.3.ebuild46
4 files changed, 6 insertions, 118 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index 25f1b11c1629..719e0b53f260 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.16 2009/09/18 21:42:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.17 2009/09/28 19:02:04 aballier Exp $
+
+ 28 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ -ocaml-sqlite3-1.2.0.ebuild, -files/ocaml-sqlite3-1.2.0-werror.patch,
+ -ocaml-sqlite3-1.5.3.ebuild:
+ remove old
*ocaml-sqlite3-1.5.6 (18 Sep 2009)
diff --git a/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.2.0-werror.patch b/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.2.0-werror.patch
deleted file mode 100644
index 3f863014d9b4..000000000000
--- a/dev-ml/ocaml-sqlite3/files/ocaml-sqlite3-1.2.0-werror.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ocaml-sqlite3-1.2.0/Makefile.in
-===================================================================
---- ocaml-sqlite3-1.2.0.orig/Makefile.in
-+++ ocaml-sqlite3-1.2.0/Makefile.in
-@@ -5,7 +5,7 @@ exec_prefix=@exec_prefix@
- bindir=@bindir@
-
- CC=@CC@
--CFLAGS=@CPPFLAGS@ @CFLAGS@ -fPIC -Wall -pedantic -Werror -Wno-long-long
-+CFLAGS=@CPPFLAGS@ @CFLAGS@ -fPIC -Wall -Wno-long-long
- LIBS=@LIBS@
- LDFLAGS=@LDFLAGS@
-
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild
deleted file mode 100644
index 0ec37e2e3092..000000000000
--- a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild,v 1.4 2009/06/21 12:03:40 aballier Exp $
-
-EAPI="1"
-
-inherit findlib eutils
-
-IUSE="doc +ocamlopt"
-
-DESCRIPTION="A package for ocaml that provides access to SQLite databases."
-SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
-HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
-
-DEPEND=">=dev-lang/ocaml-3.09
- >=dev-db/sqlite-3.3.3"
-
-RDEPEND="${DEPEND}"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
-pkg_setup() {
- if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
- eerror "In order to build ${PN} with native code support from ocaml"
- eerror "You first need to have a native code ocaml compiler."
- eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
- die "Please install ocaml with ocamlopt useflag"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
- epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
- epatch "${FILESDIR}/${PN}-1.2.0-werror.patch"
-}
-
-src_compile() {
- econf
- emake -j1 bytecode || die "make bytecode failed"
- if use ocamlopt; then
- emake -j1 opt || die "make opt failed"
- fi
- if use doc; then
- emake -j1 docs || die "make doc failed"
- fi
-}
-
-src_install() {
- findlib_src_preinst
- export OCAMLPATH="${OCAMLFIND_DESTDIR}"
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc CHANGES README TODO
- use doc && dohtml doc/*
-}
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.3.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.3.ebuild
deleted file mode 100644
index 1905d2817d2a..000000000000
--- a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.3.ebuild,v 1.1 2009/09/02 08:02:55 aballier Exp $
-
-EAPI="2"
-
-inherit findlib eutils
-
-IUSE="doc +ocamlopt"
-
-DESCRIPTION="A package for ocaml that provides access to SQLite databases."
-SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
-HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
-
-DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
- >=dev-db/sqlite-3.3.3"
-
-RDEPEND="${DEPEND}"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
- epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
- epatch "${FILESDIR}/${PN}-1.5.1-werror.patch"
-}
-
-src_compile() {
- emake -j1 bytecode || die "make bytecode failed"
- if use ocamlopt; then
- emake -j1 opt || die "make opt failed"
- fi
- if use doc; then
- emake -j1 docs || die "make doc failed"
- fi
-}
-
-src_install() {
- findlib_src_preinst
- export OCAMLPATH="${OCAMLFIND_DESTDIR}"
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc Changelog README.txt TODO
- use doc && dohtml doc/*
-}