summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-18 21:47:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-18 21:47:06 +0000
commit791b20bfc773818b43c1687aacfb1b52da6f91d2 (patch)
tree3a76bc9068cda8825a37c5f317c852c2d051f1e4 /dev-ml
parentFixing nettle dep for stable pike too (diff)
downloadhistorical-791b20bfc773818b43c1687aacfb1b52da6f91d2.tar.gz
historical-791b20bfc773818b43c1687aacfb1b52da6f91d2.tar.bz2
historical-791b20bfc773818b43c1687aacfb1b52da6f91d2.zip
version bump
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild46
-rw-r--r--dev-ml/ocamlduce/ChangeLog8
-rw-r--r--dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild70
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.1.ebuild42
6 files changed, 179 insertions, 3 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index 33b086f231a1..25f1b11c1629 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.15 2009/09/02 08:04:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.16 2009/09/18 21:42:57 aballier Exp $
+
+*ocaml-sqlite3-1.5.6 (18 Sep 2009)
+
+ 18 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.5.6.ebuild:
+ version bump
*ocaml-sqlite3-1.5.3 (02 Sep 2009)
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild
new file mode 100644
index 000000000000..376b3a83b632
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild,v 1.1 2009/09/18 21:42:57 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+ epatch "${FILESDIR}/${PN}-1.5.1-werror.patch"
+}
+
+src_compile() {
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc Changelog README.txt TODO
+ use doc && dohtml doc/*
+}
diff --git a/dev-ml/ocamlduce/ChangeLog b/dev-ml/ocamlduce/ChangeLog
index 1f10bb7bdb57..68958b1d683a 100644
--- a/dev-ml/ocamlduce/ChangeLog
+++ b/dev-ml/ocamlduce/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlduce
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.10 2009/06/20 15:17:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ChangeLog,v 1.11 2009/09/18 21:43:45 aballier Exp $
+
+*ocamlduce-3.11.1.0 (18 Sep 2009)
+
+ 18 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ +ocamlduce-3.11.1.0.ebuild:
+ version bump
20 Jun 2009; Alexis Ballier <aballier@gentoo.org> ocamlduce-3.10.2.ebuild:
define eapi before inherit
diff --git a/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild b/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild
new file mode 100644
index 000000000000..3587aaa543b7
--- /dev/null
+++ b/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlduce/ocamlduce-3.11.1.0.ebuild,v 1.1 2009/09/18 21:43:45 aballier Exp $
+
+EAPI="2"
+
+inherit versionator eutils toolchain-funcs flag-o-matic multilib
+
+OCAML_VERSION=3.11.1
+OCAML_TARBALL=ocaml-${OCAML_VERSION}.tar.bz2
+OCAML_PATCHLEVEL=1
+OCAML_GENTOO_PATCHES=ocaml-patches-${OCAML_PATCHLEVEL}.tar.bz2
+
+DESCRIPTION="OCamlDuce is a merger between OCaml and CDuce"
+HOMEPAGE="http://ocamlduce.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/225/${P}.tar.gz
+ ftp://ftp.inria.fr/INRIA/cristal/ocaml/ocaml-$(get_version_component_range 1-2 ${OCAML_VERSION})/${OCAML_TARBALL}
+ mirror://gentoo/${OCAML_GENTOO_PATCHES}"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="+ocamlopt"
+
+DEPEND="~dev-lang/ocaml-${OCAML_VERSION}[ocamlopt?]
+ >=dev-ml/findlib-1.1.2"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}/ocaml-${OCAML_VERSION}
+
+src_unpack() {
+ unpack ${P}.tar.gz ${OCAML_GENTOO_PATCHES}
+}
+
+src_prepare() {
+ cd "${WORKDIR}/${P}"
+ emake OCAML_SOURCE="${DISTDIR}/${OCAML_TARBALL}" prepare || die "failed to prepare"
+ cd "${S}"
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+}
+
+src_configure() {
+ RAW_LDFLAGS="$(raw-ldflags)" ./configure -prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/$(get_libdir)/ocaml \
+ --mandir /usr/share/man \
+ -host "${CHOST}" \
+ -cc "$(tc-getCC)" \
+ -as "$(tc-getAS)" \
+ -aspp "$(tc-getCC) -c" \
+ --with-pthread || die "configure failed!"
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce -j1 world.opt || die
+ else
+ emake -f Makefile.ocamlduce -j1 world || die
+ fi
+}
+
+src_install() {
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installbyte || die
+ if use ocamlopt; then
+ emake -f Makefile.ocamlduce BINDIR="${D}/usr/bin" LIBDIR="${D}/usr/$(get_libdir)/ocaml" installopt || die
+ fi
+ dosym /usr/$(get_libdir)/ocaml/${PN} /usr/$(get_libdir)/ocaml/site-packages/${PN}
+ dodoc Changes README
+}
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index dec60598a9b3..be0cfee3d963 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.10 2009/06/21 13:13:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.11 2009/09/18 21:47:06 aballier Exp $
+
+*postgresql-ocaml-1.12.1 (18 Sep 2009)
+
+ 18 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.12.1.ebuild:
+ version bump
*postgresql-ocaml-1.11.1 (21 Jun 2009)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.1.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.1.ebuild
new file mode 100644
index 000000000000..55c1f3b268fe
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.1.ebuild,v 1.1 2009/09/18 21:47:06 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=virtual/postgresql-base-7.3
+ >=virtual/postgresql-server-7.3"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}