summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-27 10:46:29 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-27 10:46:29 +0000
commit69d3c354e32b46af4e65c7a3b45c849d9d1f0d68 (patch)
tree2caeee8864bb6126a2546e61de44191d663418be /dev-perl/Chart
parentPPC sys-apps merge (diff)
downloadhistorical-69d3c354e32b46af4e65c7a3b45c849d9d1f0d68.tar.gz
historical-69d3c354e32b46af4e65c7a3b45c849d9d1f0d68.tar.bz2
historical-69d3c354e32b46af4e65c7a3b45c849d9d1f0d68.zip
cleanup
Diffstat (limited to 'dev-perl/Chart')
-rw-r--r--dev-perl/Chart/Chart-0.99.3_pre3.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/dev-perl/Chart/Chart-0.99.3_pre3.ebuild b/dev-perl/Chart/Chart-0.99.3_pre3.ebuild
index be0dcb7cf044..6c55967e9fcf 100644
--- a/dev-perl/Chart/Chart-0.99.3_pre3.ebuild
+++ b/dev-perl/Chart/Chart-0.99.3_pre3.ebuild
@@ -1,33 +1,33 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Chart/Chart-0.99.3_pre3.ebuild,v 1.2 2001/05/03 16:38:57 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Chart/Chart-0.99.3_pre3.ebuild,v 1.3 2002/04/27 10:34:23 seemant Exp $
-P=${PN}-0.99c-pre3
-A=${P}.tar.gz
+MY_P=${PN}-0.99c-pre3
S=${WORKDIR}/${P}
CATEGORY="dev-perl"
DESCRIPTION="The Perl Chart Module"
-SRC_URI="http://www.cpan.org/modules/by-module/Chart/${A}"
-HOMEPAGE="http://www.cpan.org/modules/by-module/Chart/${P}.readme"
+SRC_URI="http://www.cpan.org/modules/by-module/Chart/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/modules/by-module/Chart/${MY_P}.readme"
DEPEND=">=dev-perl/GD-1.19
>=sys-devel/perl-5"
src_compile() {
- perl Makefile.PL
- try make
- try make test
+ perl Makefile.PL
+ make || die
+ make test || die
}
src_install () {
- try make PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 install
- dodoc TODO MANIFEST README
-
-}
-
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ install || die
+ dodoc TODO MANIFEST README
+}