summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-05-12 16:08:31 +0000
committerTorsten Veller <tove@gentoo.org>2011-05-12 16:08:31 +0000
commite338919c7f55e3df3513c18f73295fdc6b1d399d (patch)
treeb4effd5731f19bd8cf18644f7cd9184c36024093 /dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild
parent[bump] dev-perl/PatchReader-0.9.6 (diff)
downloadhistorical-e338919c7f55e3df3513c18f73295fdc6b1d399d.tar.gz
historical-e338919c7f55e3df3513c18f73295fdc6b1d399d.tar.bz2
historical-e338919c7f55e3df3513c18f73295fdc6b1d399d.zip
[bump] dev-perl/DBD-Pg-2.18.1
Package-Manager: portage-2.2.0_alpha32/cvs/Linux x86_64
Diffstat (limited to 'dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild')
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild
new file mode 100644
index 000000000000..40ce5f55cf7a
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.18.1.ebuild,v 1.1 2011/05/12 16:08:31 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=TURNSTEP
+MODULE_VERSION=2.18.1
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}