summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-22 18:36:08 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-22 18:36:08 +0000
commitff8a5984a1236057e7cb01e05749733bd98f3697 (patch)
tree409e209da8e5fa7c0046dca57e25c427a3c52f76 /dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r1.ebuild
parentbumped current stable ebuild(s) EAPI to 5; committed directly to stable as no... (diff)
downloadhistorical-ff8a5984a1236057e7cb01e05749733bd98f3697.tar.gz
historical-ff8a5984a1236057e7cb01e05749733bd98f3697.tar.bz2
historical-ff8a5984a1236057e7cb01e05749733bd98f3697.zip
bumped EAPI to 5; committed directly to stable as no other changes present and revbump helps stable systems to keep from dieing on perl-5.18 upgrade
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0x2B6559ED
Diffstat (limited to 'dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r1.ebuild')
-rw-r--r--dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r1.ebuild b/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r1.ebuild
new file mode 100644
index 000000000000..17c12064868c
--- /dev/null
+++ b/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Lingua-Stem-Snowball-Da/Lingua-Stem-Snowball-Da-1.10.0-r1.ebuild,v 1.1 2014/08/22 18:10:15 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=CINE
+MODULE_VERSION=1.01
+inherit perl-module multilib
+
+DESCRIPTION="Porters stemming algorithm for Denmark"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 ~ppc sparc x86"
+IUSE=""
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+
+ if [[ -f ${D}/${VENDOR_LIB}/Lingua/Stem/Snowball/stemmer.pl ]] ; then
+ mv "${D}"/${VENDOR_LIB}/Lingua/Stem/Snowball/{,da-}stemmer.pl || die
+ fi
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+ elog "The stemmer.pl that ships with this distribution has been renamed to"
+ elog "da-stemmer.pl to avoid collisions with other Lingua::Stem packages."
+}