summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2014-08-24 02:53:48 +0000
committerIan Stakenvicius <axs@gentoo.org>2014-08-24 02:53:48 +0000
commite8b3c3044f923a5aa9cd9ffb428808ed56f31ac0 (patch)
tree8910de682c53d5746f4098662cfabfe21f1958ad /dev-perl/POE/POE-1.350.0-r1.ebuild
parentbumped current stable ebuild(s) EAPI to 5; committed directly to stable as no... (diff)
downloadhistorical-e8b3c3044f923a5aa9cd9ffb428808ed56f31ac0.tar.gz
historical-e8b3c3044f923a5aa9cd9ffb428808ed56f31ac0.tar.bz2
historical-e8b3c3044f923a5aa9cd9ffb428808ed56f31ac0.zip
bumped EAPI to 5; committed directly to stable as no other changes present and revbump helps stable systems to keep from dieing on perl-5.18 upgrade
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 RepoMan-Options: --force Manifest-Sign-Key: 0x2B6559ED
Diffstat (limited to 'dev-perl/POE/POE-1.350.0-r1.ebuild')
-rw-r--r--dev-perl/POE/POE-1.350.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-perl/POE/POE-1.350.0-r1.ebuild b/dev-perl/POE/POE-1.350.0-r1.ebuild
new file mode 100644
index 000000000000..8227c2dd8e7c
--- /dev/null
+++ b/dev-perl/POE/POE-1.350.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/POE/POE-1.350.0-r1.ebuild,v 1.1 2014/08/24 02:32:45 axs Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=RCAPUTO
+MODULE_VERSION=1.350
+inherit perl-module
+
+DESCRIPTION="A framework for creating multitasking programs in Perl"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ipv6 libwww ncurses tk test"
+
+RDEPEND=">=dev-perl/Event-1.09
+ >=virtual/perl-File-Spec-0.87
+ >=virtual/perl-IO-1.23.01
+ >=virtual/perl-IO-Compress-1.33
+ >=virtual/perl-Storable-2.12
+ >=dev-perl/IO-Tty-1.08
+ dev-perl/Filter
+ dev-perl/FreezeThaw
+ dev-perl/yaml
+ >=dev-perl/TermReadKey-2.21
+ >=virtual/perl-Time-HiRes-1.59
+ ipv6? ( >=dev-perl/Socket6-0.14 )
+ tk? ( >=dev-perl/perl-tk-800.027 )
+ libwww? ( >=dev-perl/libwww-perl-5.79
+ >=dev-perl/URI-1.30 )
+ ncurses? ( >=dev-perl/Curses-1.08 )"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-perl/POE-Test-Loops-${PV}
+ >=virtual/perl-Test-Harness-2.26
+ >=virtual/perl-Test-Simple-0.54
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST=do
+
+src_test() {
+ # Disable network tests
+ rm -f "${S}"/run_network_tests
+ perl-module_src_test
+}