summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-08-26 15:09:58 +0000
committerIan Delaney <idella4@gentoo.org>2013-08-26 15:09:58 +0000
commit15f18693c550c250114ccb656fe45db1b25f9feb (patch)
tree492720deef77ff3f564dccce66b122ff7fcbc850 /dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
parentdev-haskell/hashable: initial layout (diff)
downloadhistorical-15f18693c550c250114ccb656fe45db1b25f9feb.tar.gz
historical-15f18693c550c250114ccb656fe45db1b25f9feb.tar.bz2
historical-15f18693c550c250114ccb656fe45db1b25f9feb.zip
revbump -> EAPI 5
Package-Manager: portage-2.2.0/cvs/Linux x86_64 Manifest-Sign-Key: 0xB8072B0D
Diffstat (limited to 'dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild')
-rw-r--r--dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild b/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
new file mode 100644
index 000000000000..e7d31849aca1
--- /dev/null
+++ b/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SGMLSpm/SGMLSpm-1.03-r7.ebuild,v 1.1 2013/08/26 15:09:31 idella4 Exp $
+
+EAPI=5
+
+inherit eutils perl-module
+
+MY_P="${P}ii"
+S=${WORKDIR}/${PN}
+
+DESCRIPTION="Perl library for parsing the output of nsgmls"
+HOMEPAGE="http://search.cpan.org/author/DMEGG/SGMLSpm-1.03ii/"
+SRC_URI="mirror://cpan/authors/id/D/DM/DMEGG/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ cp "${FILESDIR}"/Makefile.PL "${S}"/Makefile.PL
+ epatch "${FILESDIR}"/sgmlspl.patch
+ mv sgmlspl{.pl,}
+}