summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-06-27 00:58:42 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-06-27 00:58:42 +0000
commitebdba2cc1631f1aae547761b85e27588ca9c69ca (patch)
tree85d1d436672a1b1663737370d642a44a655b1aca /dev-perl/module-build/module-build-0.18.ebuild
parentNew version of the eclass addresses a new contendor for MakeMaker, (diff)
downloadhistorical-ebdba2cc1631f1aae547761b85e27588ca9c69ca.tar.gz
historical-ebdba2cc1631f1aae547761b85e27588ca9c69ca.tar.bz2
historical-ebdba2cc1631f1aae547761b85e27588ca9c69ca.zip
Updated this ebuild because of additions to perl-modules.eclass
Diffstat (limited to 'dev-perl/module-build/module-build-0.18.ebuild')
-rw-r--r--dev-perl/module-build/module-build-0.18.ebuild48
1 files changed, 2 insertions, 46 deletions
diff --git a/dev-perl/module-build/module-build-0.18.ebuild b/dev-perl/module-build/module-build-0.18.ebuild
index 2ad370cbe28f..6ef4ab6dc3c1 100644
--- a/dev-perl/module-build/module-build-0.18.ebuild
+++ b/dev-perl/module-build/module-build-0.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.18.ebuild,v 1.1 2003/06/26 17:25:49 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/module-build/module-build-0.18.ebuild,v 1.2 2003/06/27 00:58:38 mcummings Exp $
inherit perl-module
@@ -16,48 +16,4 @@ KEYWORDS="x86 ~alpha ~arm ~hppa ~mips ~ppc ~sparc"
DEPEND="dev-perl/module-info"
-
-src_compile() {
- SRC_PREP="no"
- perl ${S}/Build.PL destdir=${D}
-}
-src_test() {
- perl ${S}/Build test
-}
-
-src_install() {
- perlinfo
- dodir ${POD_DIR}
-
- test -z ${mytargets} && mytargets="install"
- eval `perl '-V:installsitearch'`
- SITE_ARCH=${installsitearch}
- eval `perl '-V:installarchlib'`
- ARCH_LIB=${installarchlib}
- perl ${S}/Build install
-
-
- if [ -f ${D}${ARCH_LIB}/perllocal.pod ];
- then
- touch ${D}/${POD_DIR}/${P}.pod
- sed -e "s:${D}::g" \
- ${D}${ARCH_LIB}/perllocal.pod >>${D}/${POD_DIR}/${P}.pod
- touch ${D}/${POD_DIR}/${P}.pod.arch
- cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.arch
- rm -f ${D}/${ARCH_LIB}/perllocal.pod
- fi
- if [ -f ${D}${SITE_LIB}/perllocal.pod ]
- then
- touch ${D}/${POD_DIR}/${P}.pod
- sed -e "s:${D}::g" \
- ${D}${SITE_LIB}/perllocal.pod >> ${D}/${POD_DIR}/${P}.pod
- touch ${D}/${POD_DIR}/${P}.pod.site
- cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.site
- rm -f ${D}/${SITE_LIB}/perllocal.pod
- fi
-
- for FILE in `find ${D} -type f -name "*.html" -o -name ".packlist"`; do
- sed -i -e "s:${D}:/:g" ${FILE}
- done
- dodoc Change* MANIFEST* README* ${mydoc}
-}
+style="builder"